Bug 1384431 - activities screen shows applications and search results at the same time
Summary: activities screen shows applications and search results at the same time
Status: CLOSED DUPLICATE of bug 1381768
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-13 09:25 UTC by J. Haas
Modified: 2016-10-19 09:42 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-10-19 09:42:04 UTC


Attachments (Terms of Use)
screenshot (475.78 KB, image/png)
2016-10-13 09:25 UTC, J. Haas
no flags Details
screenshot2 (451.46 KB, image/png)
2016-10-13 09:25 UTC, J. Haas
no flags Details
screenshot3 (370.09 KB, image/png)
2016-10-13 09:26 UTC, J. Haas
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 742908 None None None 2016-10-14 12:11 UTC

Description J. Haas 2016-10-13 09:25:03 UTC
Created attachment 1209986 [details]
screenshot

Description of problem:

testing during the wayland fedora test day: http://testdays.fedorainfracloud.org/events/12

The activities screen looks sometimes incorrect. 

Version-Release number of selected component (if applicable):

GNOME Shell 3.22.1


How reproducible: pretty much always but not 100% reliable


Steps to Reproduce:
1. Boot https://fedorapeople.org/groups/qa/test_days/Fedora-Workstation-Live-x86_64-25-Wayland_Test_Day.iso in virt-manager
2. Close "Try/Install" dialog
2b. Optionally start some application
3. Press windows button or click in top left corner
4. quickly enter some text

Actual results:

Activity overview shows both applications and search result or both open windows and search result, which looks broken.

Additional info:

Attached some screenshots

Comment 1 J. Haas 2016-10-13 09:25 UTC
Created attachment 1209987 [details]
screenshot2

Comment 2 J. Haas 2016-10-13 09:26 UTC
Created attachment 1209988 [details]
screenshot3

Comment 3 Adam Williamson 2016-10-13 20:30:21 UTC
Can you check if this also happens with X, or if it's Wayland-only? There are instructions for switching to X in the live image on the wiki page (I hope they work OK). If it's Wayland-only, can you set the bug to block 'WaylandRelated'? Thanks!

Comment 4 J. Haas 2016-10-14 08:38:52 UTC
Not wayland related, also happens with X11. Here are clear steps to reproduce consistently:

1. Boot Live iso in vm
2. Click on activities in top left screen corner
3. Click on "show all applications" (9 dots)
4. Click again on "show all applications" (9 dots)

Expected: Applications are hidden
Actual: Applications are still visible

Only happens on live iso, installed system is fine.

Comment 5 Ricardo Ramos 2016-10-18 15:21:58 UTC
This is something I already reported and it's a very old bug, although I reported this recently because I was unable to reproduce the bug until now, the bug report is 1381768.

Comment 6 Kamil Páral 2016-10-19 09:42:04 UTC

*** This bug has been marked as a duplicate of bug 1381768 ***


Note You need to log in before you can comment on or make changes to this bug.