Bug 1384525 - OSP-9/10 upgrades fails on convergence of blockstorage.
Summary: OSP-9/10 upgrades fails on convergence of blockstorage.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 10.0 (Newton)
Assignee: Giulio Fidente
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks: 1337794
TreeView+ depends on / blocked
 
Reported: 2016-10-13 13:12 UTC by Sofer Athlan-Guyot
Modified: 2016-12-29 16:54 UTC (History)
4 users (show)

Fixed In Version: openstack-tripleo-heat-templates-compat-2.0.0-34.4.el7ost openstack-tripleo-heat-templates-5.1.0-3.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:18:59 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 381240 None None None 2016-10-13 14:48:06 UTC
Launchpad 1628912 None None None 2016-10-13 13:12:06 UTC

Description Sofer Athlan-Guyot 2016-10-13 13:12:06 UTC
Description of problem:  During major upgrade when using blockstorage, the convergence fails with:

    Could not find dependency Exec[wait-for-settle] for pacemaker::Resource::Systemd[openstack-cinder-volume]

on blockstorage node at step 5.

Version-Release number of selected component (if applicable):

openstack-tripleo-heat-templates-compat.noarch 2.0.0-34.3.el7ost @rhelosp-10.0-brew

How reproducible: always


Steps to Reproduce:
1. install osp9 with blockstorage
2. upgrade to osp10

Comment 1 Sofer Athlan-Guyot 2016-10-13 13:13:15 UTC
Adding upstream patch.

Comment 2 Sofer Athlan-Guyot 2016-10-13 14:48:07 UTC
Adding the newton/master review and removing the master one.

Comment 3 Marios Andreou 2016-10-14 07:09:45 UTC
added to blockers for upgrades RFE 1337794 and moved to POST as the fix landed into newton.

Comment 4 Marios Andreou 2016-10-14 07:11:46 UTC
re-assigned to faidentee as he actually fixed it upstream

Comment 7 Omri Hochman 2016-11-21 22:39:04 UTC
Verified with :
[root@undercloud-0 ~]# rpm -qa | grep openstack-tripleo-heat-templates
openstack-tripleo-heat-templates-compat-2.0.0-34.4.el7ost.noarch
openstack-tripleo-heat-templates-5.1.0-3.el7ost.noarch

Comment 9 errata-xmlrpc 2016-12-14 16:18:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.