Bug 1384527 - allow user to force installation of distro from excluded family
Summary: allow user to force installation of distro from excluded family
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: general
Version: 21
Hardware: Unspecified
OS: Unspecified
medium
unspecified vote
Target Milestone: 24.0
Assignee: Dan Callaghan
QA Contact: tools-bugs
URL:
Whiteboard:
Keywords: Patch
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-13 13:15 UTC by Jan Stancek
Modified: 2017-02-21 18:48 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-02-21 18:48:38 UTC


Attachments (Terms of Use)

Description Jan Stancek 2016-10-13 13:15:28 UTC
Description of problem:
There should be a way to allow user to force installation of distro from excluded family. There is <hostRequires force=""/>, but that still takes into account excluded families.

Actual results:
No way to force distro installation other than temporarily removing whole family from excluded list.

Expected results:
<hostRequires force=""/> should ignore excluded families, or some new attribute introduced that would do that.

Comment 2 Roman Joost 2016-10-17 23:57:24 UTC
Lets try to get this in Beaker 24.0

Comment 3 Dan Callaghan 2016-10-25 06:39:47 UTC
So we could adjust the pair of Recipe.candidate_systems() and Recipe.hypothetical_candidate_systems() methods (they are mirror images of each other) so that the system excluded families are not applied when force=True.

The problem is that we use hypothetical_candidate_systems() to determine which systems to show in the Reserve Workflow, when the user has picked their distro and they want to look at systems which are compatible. So even though we use force=True in the Reserve Workflow we probably *don't* want the Reserve Workflow to suddenly start offering systems which are known to be incompatible.

Comment 4 Dan Callaghan 2016-10-25 07:53:36 UTC
(In reply to Dan Callaghan from comment #3)

Seems like we might as well just divorce the Reserve Workflow system listing from the hypothetical_candidate_systems() method, it's already doing slightly different filtering (excluding Broken) and will probably have more differences in future (bug 1099142). So no big deal really.

Comment 5 Dan Callaghan 2016-10-25 07:54:42 UTC
http://gerrit.beaker-project.org/5358

Comment 7 wangdong 2016-11-09 09:22:35 UTC
Verify passed on beaker-server-24.0-0.git.194.c515848

Steps:
1. Choose a system then add RHEL 7 to it exclude distro.
2. Use Reserve workflow try to reserve this system with exclude distro.
Results:
Beaker not allow this action.

3. Use xml force install this distro.
Results:
Job can complete install.
job link -->
https://beaker-devel.app.eng.bos.redhat.com/recipes/17250#task141135

Comment 8 Dan Callaghan 2017-02-21 18:48:38 UTC
Beaker 24.0 has been released.


Note You need to log in before you can comment on or make changes to this bug.