Bug 138454 - PS/2 3 button mouse emulation not working, middle button doesn't work properly
PS/2 3 button mouse emulation not working, middle button doesn't work properly
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
All Linux
medium Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-09 08:35 EST by Simon Clift
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-09 12:18:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Clift 2004-11-09 08:35:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
I have a PS/2 two-button mouse with a "middle" button that transmits a
button 1-3 press.  In FC1 I had no problems with this being read as
button 2.  With FC3, configured with 3-button mouse emulation set in
s-c-mouse, I get results as if all three buttons were pressed, 1, 2
and 3 in sequence.

This is consistent across all of the applications I've tried
(especially konsole, firefox).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run xev
2. Use the middle mouse button
    

Actual Results:  

On "middle" mouse button press:

ButtonPress event, serial 29, synthetic NO, window 0x3000001,
    root 0x48, subw 0x3000002, time 4185732, (24,41), root:(28,62),
    state 0x0, button 2, same_screen YES

EnterNotify event, serial 29, synthetic NO, window 0x3000001,
    root 0x48, subw 0x0, time 4185733, (24,41), root:(28,62),
    mode NotifyGrab, detail NotifyInferior, same_screen YES,
    focus YES, state 512

KeymapNotify event, serial 29, synthetic NO, window 0x0,
    keys:  72  0   0   0   0   0   0   0   0   0   0   0   0   0   00
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   00

ButtonPress event, serial 29, synthetic NO, window 0x3000001,
    root 0x48, subw 0x3000002, time 4185733, (24,41), root:(28,62),
    state 0x200, button 1, same_screen YES

ButtonPress event, serial 29, synthetic NO, window 0x3000001,
    root 0x48, subw 0x3000002, time 4185733, (24,41), root:(28,62),
    state 0x300, button 3, same_screen YES

... and on button release ...

ButtonRelease event, serial 29, synthetic NO, window 0x3000001,
    root 0x48, subw 0x3000002, time 4189369, (24,41), root:(28,62),
    state 0x700, button 2, same_screen YES

ButtonRelease event, serial 29, synthetic NO, window 0x3000001,
    root 0x48, subw 0x3000002, time 4189369, (24,41), root:(28,62),
    state 0x500, button 1, same_screen YES

ButtonRelease event, serial 29, synthetic NO, window 0x3000001,
    root 0x48, subw 0x3000002, time 4189369, (24,41), root:(28,62),
    state 0x400, button 3, same_screen YES

Expected Results:  Only a middle mouse button event should have been
received by the applications.

Additional info:

This is making it hard to use a lot of applications.

I'm wondering if the emulation isn't running into trouble because the
button presses for 1 and 3 are registered at *exactly* the same time,
rather than with a separation of N  milliseconds.
Comment 1 Simon Clift 2004-11-09 09:28:30 EST
Fixed it, but I'll leave it as an anaconda bug.  Here's what seems to
have happened.

During installation anaconda saw the original Mouse0 configuration,
which was set correctly.  It seems to have added DeviceInputMouse
which didn't have the 3-button emulation set.  Any changes using
s-c-mouse affected the Mouse0 configuration, but not the second mouse
device, which was mapped to the first.

When I removed the second mouse device and restarted X everything
returned to normal.

However, perhaps a change is warranted in anaconda to prevent this,
since it seems to have confused all of the GUI configuration tools and
would leave a novice user in a fix.
Comment 2 Kristian Høgsberg 2004-11-09 12:18:18 EST
Sounds good, that's what I thought it would be.  We've seen similar
problems where buttons 1 and 3 was swapped for one of the devices, and
clicking one button would give both button 1 and 3 events.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.