Bug 13846 - Shutdown hangs with serial console and no cable
Shutdown hangs with serial console and no cable
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: SysVinit (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-12 21:41 EDT by Viraj Alankar
Modified: 2014-03-16 22:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-12 21:41:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Viraj Alankar 2000-07-12 21:41:40 EDT
I have setup a system with serial console and when running the following 
command when there is no serial cable connected:

reboot

The system is not rebooted. It seems to be waiting for the getty to die. 
Killing the getty continues the reboot process.

I have the following in my /etc/inittab:

# Serial console
S2:12345:respawn:/sbin/getty ttyS0 9600 vt100

any my kernel is booted with arguments:

console=tty0 console=ttyS0

Not sure what is the cause of this problem.

Thanks.
Comment 1 Pekka Savola 2000-07-19 07:17:00 EDT
I looked a bit into this.

This only happens if serial console is the primary console (the last
definition).

Using 9600 in getty is bad.  See /etc/gettydefs.  CRTSCTS flow control is being
used.  This isn't usually what you want with serial consoles.  

Switch to DT9600 (Dumb Terminal) to get this to work properly.

Still an "issue" in Rawhide as of 19 Jul 2000.

Note You need to log in before you can comment on or make changes to this bug.