Bug 1384631 - Fail to run 'tempest.api.network.test_dhcp_ipv6.NetworksTestDHCPv6' tests
Summary: Fail to run 'tempest.api.network.test_dhcp_ipv6.NetworksTestDHCPv6' tests
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tempest
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
medium
urgent
Target Milestone: rc
: 10.0 (Newton)
Assignee: Ihar Hrachyshka
QA Contact: tkammer
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-13 17:39 UTC by Arie Bregman
Modified: 2016-12-14 16:19 UTC (History)
12 users (show)

Fixed In Version: openstack-tempest-13.0.0-2.bafe630git.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:19:11 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 383659 None None None 2016-10-17 19:00:58 UTC

Description Arie Bregman 2016-10-13 17:39:57 UTC
Description of problem:

Fail to run all the tests under 'tempest.api.network.test_dhcp_ipv6.NetworksTestDHCPv6'.

Version-Release number of selected component (if applicable): 
openstack-neutron-9.0.0-0.20160929051647.71f2d2b.el7ost.noarch


How reproducible: 100%


Steps to Reproduce:
1. Deploy RHOSP 10 HA
2. Run Tempest API DHCP IPv6 tests

Actual results:
---
Traceback (most recent call last):
  File "/home/stack/tempest/tempest/api/network/test_dhcp_ipv6.py", line 378, in tearDown
    self._clean_network()
  File "/home/stack/tempest/tempest/api/network/test_dhcp_ipv6.py", line 81, in _clean_network
    self.subnets_client.delete_subnet(subnet['id'])
  File "/home/stack/tempest/tempest/lib/services/network/subnets_client.py", line 52, in delete_subnet
    return self.delete_resource(uri)
  File "/home/stack/tempest/tempest/lib/services/network/base.py", line 41, in delete_resource
    resp, body = self.delete(req_uri)
  File "/home/stack/tempest/tempest/lib/common/rest_client.py", line 307, in delete
    return self.request('DELETE', url, extra_headers, headers, body)
  File "/home/stack/tempest/tempest/lib/common/rest_client.py", line 665, in request
    resp, resp_body)
  File "/home/stack/tempest/tempest/lib/common/rest_client.py", line 778, in _error_checker
    raise exceptions.Conflict(resp_body, resp=resp)
tempest.lib.exceptions.Conflict: An object with that identifier already exists
Details: {u'message': u'Unable to complete operation on subnet 21dfe8c4-ca26-48c8-a621-8e4b1fe099e7: One or more ports have an IP allocation from this subnet.', u'type': u'SubnetInUse', u'detail': u''}
---

Expected results: Tests passed successfully

Additional info: Link to Jenkins job with the test results provided in the next comment

Comment 8 Ihar Hrachyshka 2016-10-20 14:54:13 UTC
AFAIK the fix got into RDO tempest, and CI does not show this specific type of failure for the test anymore. Also, openstack-tempest package is built in brew.

Comment 12 Arie Bregman 2016-11-04 15:04:32 UTC
Verified there are no API failures anymore.

Comment 14 errata-xmlrpc 2016-12-14 16:19:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.