This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 138465 - docs are lacking or broken in some places
docs are lacking or broken in some places
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: selinux-faq (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Wade
Karsten Wade
http://fedora.redhat.com/docs/selinux...
:
Depends On:
Blocks: 118757
  Show dependency treegraph
 
Reported: 2004-11-09 09:26 EST by Thomas Vander Stichele
Modified: 2007-04-18 13:14 EDT (History)
2 users (show)

See Also:
Fixed In Version: FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-27 19:57:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas Vander Stichele 2004-11-09 09:26:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020 Epiphany/1.4.4

Description of problem:
- http://fedora.redhat.com has one link to SELinux, which links to a
project page that seems to be from before FC2 (!) and has no mention of
documentation
- The "docs" link below that links to the docs as a project, not to
docs.  Maybe not that bad, but confusing.
- The docs link on the left links to docs, where SELINUX is listed, and
the link mentions that it is for FC3 test 2
- When you click it, the docs say it is for test *3*
- all internal links in that doc are broken
- some commands in that doc do not work: fixfiles, audit2allow
- the document is more of a FAQ than a Howto, a simple "getting started"
would help a lot.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. buy a computer
2. install FC3 on it
3. surf to http://fedora.redhat.com/docs/selinux-faq-fc3/index.html
    

Actual Results:  I managed to not figure out how to do stuff with SELinux

Expected Results:  I should have easily fixed my system based on the
excellent docs then move on to the order of the day

Additional info:

I'm filing this after being asked to after sending a mail to fedora-devel

please HELP SAVE SELINUX by putting an end to the negative energy
concentrating to fight it !!! YOU TOO CAN HELP
Comment 1 Dave Malcolm 2004-11-09 11:38:41 EST
Adding walters to cc as he's been working on some SELinux/Apache
documentation.
Comment 2 Karsten Wade 2004-11-09 13:19:28 EST
Thanks for bringing these to our attention.  Here are the quick fixes:

> The "docs" link below that links to the docs as a project, 
> not to docs.  Maybe not that bad, but confusing.

This is a usability issue we need to consider.  Perhaps renaming the
navigation to be Projects > Docs Project?  We regularly receive
traffic on fedora-docs-list from people looking for documentation,
whereas the Docs Project is for creating documentation.  Fine line. 
More thought needed here.

> The docs link on the left links to docs, where SELINUX is listed,
> and the link mentions that it is for FC3 test 2

Oops.  Fixed, should be live within the hour.

> When you click it, the docs say it is for test *3*

When this document was updated last (22-OCT-2004), it was current for
test3.  With the release yesterday of FC3 final, I have updated the
title to say just Fedora Core 3.  This should be live within the hour.

> all internal links in that doc are broken

Recently known issue due to a problematic script on fedora.redhat.com,
fixed this morning, changes are already live.

> some commands in that doc do not work: fixfiles, audit2allow

Yes, there was an instance where fixfiles is shown using a directory
path.  This has been fixed, and language has been added to make the
usage for fixfiles and audit2allow more clear.

> the document is more of a FAQ than a Howto, a simple "getting 
> started" would help a lot.

The Fedora Documentation Project needs writers.  If you know of anyone
who is interested in writing a kind of getting started guide, send
them to fedora-docs-list, and we'll get them started.

Soon for release is a tutorial on using Apache and SELinux.  When this
is ready, we'll announce it on the relevant mailing lists.

This bug has been set to block bug #118757, which is the tracker bug
for reports against the SELinux FAQ.

The version reported against was selinux-faq-1.3-2
(2004-10-22-T16:20-0800).  Current version is selinux-faq-1.3-3
(2004-11-09-T16:20-0800).
Comment 3 Karsten Wade 2005-12-27 19:57:48 EST
All this has been long resolved, closing.

Note You need to log in before you can comment on or make changes to this bug.