Bug 138479 - Second DVI display not working with ATI FireGL Z1-128
Second DVI display not working with ATI FireGL Z1-128
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Depends On:
  Show dependency treegraph
Reported: 2004-11-09 10:25 EST by Sean E. Millichamp
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-02-11 16:55:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
The original xorg.conf file which worked under FC2 (3.99 KB, text/plain)
2004-11-09 10:32 EST, Sean E. Millichamp
no flags Details
Xorg.0.log output (47.89 KB, text/plain)
2004-11-09 10:36 EST, Sean E. Millichamp
no flags Details
6.7.0 log (59.86 KB, text/plain)
2004-12-21 11:16 EST, Mathieu Chouquet-Stringer
no flags Details log (61.77 KB, text/plain)
2004-12-21 11:16 EST, Mathieu Chouquet-Stringer
no flags Details
Diff between 6.7.0 and (22.39 KB, text/plain)
2004-12-21 11:17 EST, Mathieu Chouquet-Stringer
no flags Details

  None (edit)
Description Sean E. Millichamp 2004-11-09 10:25:35 EST
Description of problem:
I had a working Xinerama dual-head configuration with Fedora Core 2
using the Xorg radeon driver.  My configuration is a dual DVI panel
setup with two 1600x1200 Viewsonic LCDs and an ATI FireGL Z1-128 card.

When I upgraded to FC3 the config file would initialize the second
display (it came out of power saving mode) and "Out of Range" would
appear on it (from the monitor's OSD) and the display would remain black.

The GNOME Workplace Switcher applet showed that my desktop was the
expected 3200x1200.  Also, /var/log/Xorg.0.log showed that both
screens apparently initialized properly.

I tried a number of variations in the xorg.conf settings without
success, including attempting to use MergedFB and with MergedFB
explicitly disabled.

I tried creating an xorg.conf from scratch using system-config-display
but I think I encountered:

So I ended up just modifying existing ones I had (including the
working FC2 xorg.conf file)

How reproducible:
Comment 1 Sean E. Millichamp 2004-11-09 10:32:17 EST
Created attachment 106347 [details]
The original xorg.conf file which worked under FC2

I made a backup copy of my xorg.conf file before upgrading (in the event
anaconda ate it).  This configuration worked perfectly in FC2.

One note: The manually specified HorizSync/VertRefresh and Modeline I added to
fix a display problem due to some apparently incompatibility between my card
and the Viewsonic VP201s displays I am using.  If I remove them it would still
work under FC2, but the display would flicker and be a little shaky.  I've
tried FC3 with and without them and I get the same results either way.
Comment 2 Sean E. Millichamp 2004-11-09 10:36:17 EST
Created attachment 106348 [details]
Xorg.0.log output

I couldn't find anything obviously wrong when reading the server output but
hopefully it will be of help to folks smarter then I :)
Comment 3 Philip Van Hoof 2004-11-09 13:15:59 EST
It's possible that this is related to

Feel free to mark one of both as a duplicate if it does fix your problem.
Comment 4 Sean E. Millichamp 2004-11-10 10:47:32 EST

I looked at bug # 138500 and according to my Xorg.0.log X was not
attempting to use framebuffer support but I explictly disabled it
anyway - no change.

I also have tried using the MonitorLayout option (and not using it) to
no avail.

Thanks for the suggestion though.
Comment 5 Sean E. Millichamp 2004-11-10 10:51:56 EST
I have a kludgy workaround the restores my computer back to my FC2
dual-head niceness in the meantime:

I rpm -e --nodeps the following:

and then rpm -i'd:

... which were all pulled from the FC2 update packages.

I am running that way right now and it seems to work just fine.  Not a
fix, of course... but it does let me enjoy the rest of FC3 and saves
me from having to reinstall FC2.
Comment 6 Jim Cornette 2004-11-13 22:04:51 EST
Having to drop back to xorg-x11 in order to get this screen to work is
not a solution but appropriate "workaround" so you can get FC3 in
almost all of its glory.

If you basckup your xorg.conf file and run system-config-display, does
your config file stay in a workable state? This is mainly because the
config file that I had for a dual boot configuration seemed to point
to the configuration program.
Comment 7 Chris Hubick 2004-11-29 05:37:35 EST
I would like to confirm this bug.

I use a FireGL Z1 with two DVI monitors.  I have different resolution
monitors, and do NOT use Xinerama, but rather separate desktops.

My dual head was configured and worked fine under FC2.

Using the xorg.conf created by the FC3 install, or using my xorg.conf
from FC2, with the X.org binary from FC3 my second monitor came out of
sleep mode but displayed nothing.  IIRC, I could move the mouse onto
the non-displayed desktop screen while within X.

I thus (somewhat painstakingly) reverted back to the latest FC2 X
packages, and everything works again.
Comment 8 Mathieu Chouquet-Stringer 2004-12-03 08:51:58 EST
Same comment here except that I've got a dual dual-head (2 radeon
chips on one card).
The second set of dual-head works fine but on the primary, display
number one is almost ok except for a corrupted rectangular shaped area
at the bottom of the screen (some kind of memory overlap/detection as
i lose the mouse cursor amongst other) and display number two,
eventhough it wakes up from sleep mode, remains black.
My fix (like others) was to switch back to FC2 xorg-x11, which works well.

I had reported this bug to freedesktop.org (bug #1214) a little while ago.
Comment 9 Chris Hubick 2004-12-08 16:58:00 EST
Thanks for the freedesktop.org bug info Mathieu.

For easy clicking by all:
Comment 10 Stephen Adler 2004-12-11 17:19:01 EST
I would like to report that I'm having a similar problem. The
difference is that I have an ATI FireGL X1. Here are some oddities
which I can report.

1) If I create a new user, when I log under the gnome desktop xinerama
works great.
2) After working under the new user account, (i.e. changing
backgrounds, themes, windowing behavior, adding applete to panel,
reading e-mail, etc.) when I log out, and log back in, 2nd display
stops working.
3) If I create a 2nd new user, and log in fresh under the 2nd new
user, xinerama works again.
4) If I log in under KDE, and I go to the configure desktop utility,
when I apply the desktop settings, the 2nd monitor springs to life.

Hope this added info helps in debuging the problem.
Comment 11 Sean E. Millichamp 2004-12-14 14:52:41 EST
I just tried the xorg-x11-6.8.1-12.FC3.21 updates to see if they
resolved this problem.  I thought that they might based on a comment
in https://bugs.freedesktop.org/show_bug.cgi?id=1559 (which is linked
from the bug mentioned above as possibly being related) that indicated
a potential fix had been included in that release.

Initially, it seemed to solve the problem as I was able to 'startx'
and get both screens initialized.  However, I triggered what is
apparently a bug in the xorg-x11-6.8.1-12 release (relating to
switching to virtual consoles using CTRL-ALT-Fn from X) and had to
reboot my system.  After the reboot I was back to the same behavior as

One thing I noticed is that it seems if you startx in
xorg-x11-6.7.0-11 first then xorg-x11-6.8.1-12 will work until the
next reboot.  Perhaps some display initialization is missing in 6.8.1
that occurred in 6.7.0?
Comment 12 Mathieu Chouquet-Stringer 2004-12-14 15:31:23 EST
Same exact behaviour here in regards to switching back to VTs (which
doesn't work) or starting 6.7 and then 6.8.
Comment 13 Mathieu Chouquet-Stringer 2004-12-14 15:34:46 EST
BTW Thanks Chris for posting the links
Comment 14 Mathieu Chouquet-Stringer 2004-12-21 11:15:24 EST
Just tested 6.8.2rc1 a.k.a by Mike A. Harris.

We're almost there. 3 out of the 4 displays are working. The last one
is on but displays nothing (black screen).

On the plus side, the memory detection seems to be ok as I don't get
this overlap anymore at the bottom of the screen.

I'm attaching log file for 6.7.0 and and a diff between
these two.

Comment 15 Mathieu Chouquet-Stringer 2004-12-21 11:16:26 EST
Created attachment 108956 [details]
6.7.0 log
Comment 16 Mathieu Chouquet-Stringer 2004-12-21 11:16:57 EST
Created attachment 108957 [details] log
Comment 17 Mathieu Chouquet-Stringer 2004-12-21 11:17:34 EST
Created attachment 108958 [details]
Diff between 6.7.0 and
Comment 18 Mike A. Harris 2005-01-15 02:45:00 EST
Comment 19 Mathieu Chouquet-Stringer 2005-01-18 09:06:13 EST
Tested with xorg version (6.8.2rc2, rpms in rawhide by
Mike A. Harris), same thing.
Comment 20 Mike A. Harris 2005-02-11 16:55:14 EST
This does not appear to be a Red Hat specific problem, but rather
a general problem with the upstream X.Org radeon driver.  We will
track this issue in the X.Org bugzilla now, and will review any
patches that become available for consideration in future Fedora
Core updates.  Please make all future status updates and test
result comments in the X.Org bug report.  Thanks in advance.

Setting bug status to "UPSTREAM" for tracking in the X.Org bugzilla.
Comment 21 Stephen Adler 2005-08-21 12:23:03 EDT
guys, This problem may be an xscreen saver problem. Check bug #166445 for
further details. The way I made my second screen work again was by disabing and
re enabling the screen saver, going through the preferences memu.


This bug had me pulling at my hair since fc3 was released. Without falling back
to a fc2 xorg setup, I can now use my two LCD screens in xinerama mode. (I have
an ATI FireGL Z1)
Comment 22 Ken Kennedy 2005-09-26 16:46:24 EDT
OMG...this (the screensaver disable/reenable) worked for me! I'm running Ubuntu,
bug was having a similar issue...so it's definitely not RH specific. Thanks for
the info, Stephen!!

Comment 23 Stephen Adler 2005-09-26 17:41:51 EDT
No problem Ken, I'm sure its an Xorg problem. Typically what happens is the

1) Create a new user and log in for the first time as this new user
   -- Only one screen is alive at the X11 display login screen.
   -- Both screens come alive when you log in.

2) You configure the screen saver, then log out and log back in as this new user.
   -- Only one screen is alive at the X11 display login screen.
   -- Only one screen is alive after you logged in.
   -- You have to disable then re-enable the screen saver and
      your second screen comes alive.

3) Log out, go way for a *long* time, (i.e. go to sleep come back the next morning)
   -- Your screen will have gone into hybernate mode.
   -- When you shake your mouse to bring it out of hybernate mode *both* screens
will be alive at the X11 display login screen.
   -- When you log in, both screens will be alive, without having to disable and
reenable the screen save.

OK... So, someone needs to put there thinking cap on as to what is going on. I
believe that the problem lies in the inializtion of the card. Disabling and
Re-enabling exersizes the proper card initalziation code for the two screens
within the driver. Coming out of hybernation also executes the code which
properly initalizes the second screen.

At least a work around has been discovered. Now its up to the Open Source
community to fix the code.... (I wish I had the time to dig through 10000's of
lines of X11 code....)
Comment 24 Chris Hubick 2006-03-23 16:59:22 EST
Sorry for the bugspam... but have any of you fellow FireGL users tried FC5 yet?

After several days tinkering I have not been able to get the radeon driver to
work on my Z1 at *all* (single or dual head).  I had to install FC5 in text
mode.  Booting the FC4 install disc, X comes up fine still.

Looks like I'm really stuck with ATI's binary fglrx driver now.
Comment 25 Sean E. Millichamp 2006-03-24 10:19:45 EST
Ch(In reply to comment #24)
> Sorry for the bugspam... but have any of you fellow FireGL users tried FC5 yet?

I installed it Monday and while it did take some tinkering, I did get both
displays working just fine (minus OpenGL support, of course) with the included
driver.  Using the included display config tool I could only get it operating in
clone mode.  I had to manually configure it for MergedFB mode before I could get
a spanning desktop.

My card: PCI:*(1:0:0) ATI Technologies Inc R300 AG [FireGL Z1/X1] rev 128

I did do a fresh-from-scratch install as opposed to an upgrade.  Perhaps if you
did an upgrade there is some artifact of your previous install (something in the
config or maybe an old X library somewhere in one of the search paths) that is
causing problems.

Note You need to log in before you can comment on or make changes to this bug.