Bug 1384809 - libsemanage.add_user: user system_u not in password file
Summary: libsemanage.add_user: user system_u not in password file
Keywords:
Status: CLOSED DUPLICATE of bug 1378204
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-14 08:32 UTC by Kamil Páral
Modified: 2016-10-14 08:41 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-14 08:41:16 UTC


Attachments (Terms of Use)

Description Kamil Páral 2016-10-14 08:32:43 UTC
Description of problem:
During the last two dnf updates, I started seeing this:

  Upgrading   : selinux-policy-3.13.1-219.fc25.noarch                                                    15/230 
libsemanage.add_user: user system_u not in password file

So either system_u user creation failed for some reason (and should be fixed), or it is a harmless warning, and in that case, can you please not print it? Only real errors should be printed, anything else will just clutter the output and make people overlook the real errors.

Thanks.


Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-219.fc25.noarch

Comment 1 Petr Lautrbach 2016-10-14 08:41:16 UTC
Thanks for the report.

It's a harmless warning and system_u will be removed from SELinux users in the next update.

*** This bug has been marked as a duplicate of bug 1378204 ***


Note You need to log in before you can comment on or make changes to this bug.