Bug 138481 - MonitorsDB needs to have Apple monitors added to it
MonitorsDB needs to have Apple monitors added to it
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hwdata (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-09 10:26 EST by Barry K. Nathan
Modified: 2014-03-16 22:50 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.146-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-09 15:19:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch: merge hwdata-0.121-1.ydl.7 MonitorsDB changes into hwdata-0.145-1 (2.51 KB, patch)
2004-11-09 10:57 EST, Barry K. Nathan
no flags Details | Diff

  None (edit)
Description Barry K. Nathan 2004-11-09 10:26:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040914

Description of problem:
Any attempt to manually specify an Apple monitor in
system-config-display fails because there are no Apple monitors in
MonitorsDB. It should be possible to specify Apple monitors just like
other monitors.

Yellow Dog Linux has a patched hwdata that includes Apple monitors.
However, that doesn't help when you're trying to use an Apple monitor
on a DDC-challenged x86 box (a real-world situation I ran into just
yesterday). Therefore I wish to merge the Yellow Dog changes upstream.
I will attach a tested patch to do just that.

Version-Release number of selected component (if applicable):
hwdata-0.145-1

How reproducible:
Always

Steps to Reproduce:
1. Shout "FireGL!" in a crowded Bugzilla... uh, I mean... set up
Fedora Core on a box where the video card BIOS doesn't support DDC
(seriously, ancient FireGL cards work very well for this).
2. Try to manually specify your Apple monitor in anaconda or
system-config-display.
    

Actual Results:  No Apple monitors are listed.

Expected Results:  Apple monitors should be listed.

Additional info:
Comment 1 Barry K. Nathan 2004-11-09 10:57:45 EST
Created attachment 106351 [details]
patch: merge hwdata-0.121-1.ydl.7 MonitorsDB changes into hwdata-0.145-1

This patch adds Apple monitors to MonitorsDB. This brings hwdata-0.145 up to
date with Yellow Dog Linux 4.0. I have tested this patch on an "Apple Studio
Display 15 LCD (pre-2001)" connected to a Diamond FireGL 1000 Pro (with my
patch from bug 108681 as well). I got a better-looking picture (due to a
different refresh rate) than with the Generic 1024x768 LCD setting.
Comment 2 Bill Nottingham 2004-11-09 12:42:14 EST
Added in 0.146-1.

Note You need to log in before you can comment on or make changes to this bug.