Bug 1384843 - Latest xorg server freezes KDE's plasma desktop
Summary: Latest xorg server freezes KDE's plasma desktop
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 25
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1399396 (view as bug list)
Depends On:
Blocks: 1399396
TreeView+ depends on / blocked
 
Reported: 2016-10-14 09:01 UTC by Martin Kho
Modified: 2017-03-11 09:43 UTC (History)
15 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-01-13 02:24:33 UTC


Attachments (Terms of Use)
xdpyinfo output (116.44 KB, text/plain)
2016-12-11 13:24 UTC, LarryO
no flags Details
xvinfo output (1.88 KB, text/plain)
2016-12-11 13:24 UTC, LarryO
no flags Details

Description Martin Kho 2016-10-14 09:01:13 UTC
Description of problem:
This is a HP workstation with two dispays driven by a ati radeon video card. The workspace, panel and any widgets on the desktop and systemtray get frozen at some moments, running applications (e.g. dolpin, console, firefox) are not affected they function normal. Swithing between virtual desktops is mostly not very smoothly. Application 'hang' in the middel of the two screens, or show up just partly. In most cases these artefacts are gone when moving the mouse cursor. This made me think that libinput is the culprit, but downgrading xorg-x11-libinput didn't solve the hole issue.

During/after the freeze there is nothing in Xorg.0.log, nor in systemd's journal.

I can temporarily 'solve' the issue by swithing to a virtual terminal (CTRL-ALT-Fx) desktop. Downgrading xorg-x11-server (and some drv friends) makes everything working again as expected.

It's - for me - unclear what exactly triggers this issue. May be it has something to do with: "Add a fix from upstream to fix input devices no longer working after a vt-switch"

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.19.0-0.2.20160929.fc25

How reproducible:
always, but it's not clear when it happens.

Steps to Reproduce:
Rather difficult to say, but may be swithing a lot between virtual desktops can help to trigger this issue.

Actual results:
Plasma desktop, panel, widgets are freezing

Expected results:
No freezing desktop, panel and widgets

Additional info:

Comment 1 Kalle Korhonen 2016-11-25 19:20:04 UTC
I have the same X.org version as above but Thinkpad W520 and Nvidia card w/ Nouveau drivers. After updating from 24 to 25, as soon as I run "intel-virtual-output" the plasmashell first freezes and then crashes. I created a new user as well but it crashes the same way so it's not because of any old KDE configuration. I can sometime restart plasmashell but the whole X session crashes if I launch any new applications. Same resolution, downgrading to "sudo dnf --allowerasing --releasever=24 downgrade xorg-x11-server-Xorg" fixes everything. Didn't find any meaningful entries in journal.

Comment 2 LarryO 2016-12-11 13:09:40 UTC
I have this as well with a fresh install of Fedora 25 KDE Spin using NVIDIA GK107 (GeForce GT 640 OEM) rev a1.

Comment 3 LarryO 2016-12-11 13:23:22 UTC
Running with current updates, xorg-x11-server-Xorg-1.19.0-1.fc25.x86_64 and xorg-x11-drv-nouveau-1.0.13-1.fc25.x86_64.

Comment 4 LarryO 2016-12-11 13:24 UTC
Created attachment 1230582 [details]
xdpyinfo output

Comment 5 LarryO 2016-12-11 13:24 UTC
Created attachment 1230583 [details]
xvinfo output

Comment 6 Ian Pilcher 2016-12-11 15:44:40 UTC
What X.org "and friends" versions are you running that work?

Comment 7 Martin Kho 2016-12-11 15:59:51 UTC
xorg-x11-server_Xorg 1.18.4-6. 

The following packages were updated:
xorg-x11-server-Xorg
xorg-x11-drv-wacom
xorg-x11-drv-vmware
xorg-x11-drv-vesa
xorg-x11-drv-synaptics
xorg-x11-drv-qxl
xorg-x11-drv-openchrome
xorg-x11-drv-nouveau
xorg-x11-drv-libinput
xorg-x11-drv-intel
xorg-x11-drv-fbdev
xorg-x11-drv-evdev
xorg-x11-drv-ati

Comment 8 Raphael Groner (DAASI International) 2016-12-14 08:21:48 UTC
Isn't this now a duplication of bug #1399396?

Comment 9 Fedora Update System 2017-01-11 22:09:13 UTC
xorg-x11-server-1.19.1-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-4e17feecd9

Comment 10 Kalle Korhonen 2017-01-12 00:06:16 UTC
Regarding bug #1399396, I tried setting Option "DRI" "3" in my nouveau config but plasma still crashes. However, perhaps there was some difference since plasma doesn't freeze but just crashes right away and then reboots (to login screen). Could be a different version of Xorg as well, tried with 1.19.0-3.fc25 before downgrading back to 1.18.4-5.fc24. Will try 1.19.1 once it becomes available.

Comment 11 Fedora Update System 2017-01-12 07:53:49 UTC
xorg-x11-server-1.19.1-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-4e17feecd9

Comment 12 Martin Kho 2017-01-12 08:34:36 UTC
Hi,

Yeah, xorg-x11-server-1.19.1-1.fc25 indeed solves this issue. No need to enable dri3. It's rock solid again.

Thanks,

Martin Kho

Comment 13 Jason Tibbitts 2017-01-12 18:25:16 UTC
*** Bug 1399396 has been marked as a duplicate of this bug. ***

Comment 14 Colin J Thomson 2017-01-12 20:19:48 UTC
I removed my temp xorg.conf which I created to enabled DRI 3 as mentioned in #1399396 and since applying this update I have had no freezes in over 12 hours.

Thanks very much.

Comment 15 Fedora Update System 2017-01-13 02:24:33 UTC
xorg-x11-server-1.19.1-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Raphael Groner (DAASI International) 2017-01-13 08:21:48 UTC
No freezes here any more, too. Thanks!


Note You need to log in before you can comment on or make changes to this bug.