Bug 138499 - Installer fails: No hard drives found using ahci
Installer fails: No hard drives found using ahci
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-09 12:49 EST by Jan Poos
Modified: 2015-01-04 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-02 21:07:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Poos 2004-11-09 12:49:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Boot/Install from cdrom FC3-i386-disc1
Installer gives Warning: No hard drives found. Choose manually device 
drivers.
I choose the AHCI driver.
Install continues until the part to partition the hard drives. 
Installer stops with No drives found and reboots.

Config: Dell 8400 dimension with 2 hard disks, Intel 82801 FR SATA 
RAID controller (ICH6R) configured in BIOS SATA/AHCI Raid 0

I expected AHCI to be supported due to 2.6.9-rc3-libata-dev1 patch is 
part of the Kernel 2.6.9 and because I can choose the AHCI as a 
driver option during install.
By the way I also tried the ata_piix driver, but same result.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot from install disk
2.choose AHCI as driver when no hard disk is found
3.continue until the partition part and it will fail
    

Actual Results:  Not able to install fc3test3. Installer stops and 
reboots.

Expected Results:  The AHCI driver should be able to detect the hard 
drives and be able to partition.

Additional info:
Comment 1 Bill Nottingham 2004-11-09 15:59:45 EST
You need to use ata_piix, not AHCI at this point.
Comment 2 Jan Poos 2004-11-09 17:05:04 EST
I tried with ata_pixx:
At the point installer asks for "no hard drive found. select drivers 
now?"
I selected the "Intel PIIX/ICH ATA controllers(ata_piix)" option and 
installer continues until the partition part ( I both tried a/ auto 
partion and b/ manual part), but then installer fails with "No drives 
found etc." Pushing OK makes the installer stop and reboots
Comment 3 Dave Jones 2004-11-09 18:07:50 EST
fc3 final should be defaulting to using ata_piix
Comment 4 Jan Poos 2004-11-10 11:30:57 EST
Sorry, I saw I accidentaly had checked the fc3test3 version in stead 
of fc3! I've corrected this. It's all about FC3!
Comment 5 Satish Katiyar 2005-02-23 21:53:07 EST
I see the exactly same problem with my new Dell Precision 370 
Workstation and Fedora Core 3. FC3 installation doesn't recognize my 
SATA driver. This drive currently has (factory installed) Windows XP 
which is running fine. Dell technical support tells me that it's a 
bug in FC3. The workaround is to install kernel 2.6.9-
1.681_fc3_sata.root.i686.rpm on a SCSI disk, then mirror it on the 
SATA disk and boot the system in rescue mode (or some voodoo like 
that).

The SATA reported by Windows XP on this system (P4 EM64T 3.2GHz) is 
as follows
Name	Intel(R) 82801FB/FBM Ultra ATA Storage Controllers - 266F
Manufacturer	Intel
Status	OK
PNP Device ID	PCI\VEN_8086&DEV_266F&SUBSYS_01751028&REV_03
\3&172E68DD&0&F9
I/O Port	0x0000FFA0-0x0000FFAF
Driver	c:\windows\system32\drivers\pciide.sys (5.1.2600.0 
(XPClient.010817-1148), 3.25 KB (3,328 bytes), 12/31/1979 10:00 PM)
	
Name	Primary IDE Channel
Manufacturer	(Standard IDE ATA/ATAPI controllers)
Status	OK
PNP Device ID	PCIIDE\IDECHANNEL\4&FEE6D1B&0&0
I/O Port	0x000001F0-0x000001F7
I/O Port	0x000003F6-0x000003F6
IRQ Channel	IRQ 14
Driver	c:\windows\system32\drivers\atapi.sys (5.1.2600.2180 
(xpsp_sp2_rtm.040803-2158), 93.13 KB (95,360 bytes), 12/31/1979 10:00 
PM)
	
Name	Intel(R) 82801FR SATA AHCI Controller
Manufacturer	Intel
Status	OK
PNP Device ID	PCI\VEN_8086&DEV_2652&SUBSYS_01751028&REV_03
\3&172E68DD&0&FA
I/O Port	0x0000FE00-0x0000FE07
I/O Port	0x0000FE10-0x0000FE13
I/O Port	0x0000FE20-0x0000FE27
I/O Port	0x0000FE30-0x0000FE33
I/O Port	0x0000FEA0-0x0000FEAF
Memory Address	0xDFFFFC00-0xDFFFFFFF
IRQ Channel	IRQ 20
Driver	c:\windows\system32\drivers\iastor.sys (4.5.0.6515, 466.75 KB 
(477,952 bytes), 6/29/2004 10:17 AM)
Comment 6 Dave Jones 2005-07-15 14:53:36 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 7 Dave Jones 2005-10-02 21:07:32 EDT
This bug has been automatically closed as part of a mass update.
It had been in NEEDINFO state since July 2005.
If this bug still exists in current errata kernels, please reopen this bug.

There are a large number of inactive bugs in the database, and this is the only
way to purge them.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.