Bug 1385153 - rhel-osp-director: Deployment with instruction to wipe disks on ceph fails: No connection adapters were found for 'file:///home/stack/wipe-disk.sh'",
Summary: rhel-osp-director: Deployment with instruction to wipe disks on ceph fails:...
Keywords:
Status: CLOSED DUPLICATE of bug 1380902
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: 10.0 (Newton)
Assignee: Angus Thomas
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-14 20:10 UTC by Alexander Chuzhoy
Modified: 2016-10-14 20:17 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-14 20:17:19 UTC


Attachments (Terms of Use)

Description Alexander Chuzhoy 2016-10-14 20:10:28 UTC
rhel-osp-director:   Deployment with instruction to wipe disks on ceph fails: No connection adapters were found for 'file:///home/stack/wipe-disk.sh'"


Environment:
openstack-puppet-modules-9.0.0-0.20160915155755.8c758d6.el7ost.noarch
openstack-tripleo-heat-templates-5.0.0-0.20161003064637.d636e3a.1.1.el7ost.noarch
instack-undercloud-5.0.0-0.20160930175750.9d2a655.el7ost.noarch
puppet-ceph-2.2.0-1.el7ost.noarch


Steps to reproduce:

1. Attempt to deploy overcloud with:
openstack overcloud deploy --templates --control-scale 3 --compute-scale 2 --neutron-network-type vxlan --neutron-tunnel-types vxlan --ntp-server clock.redhat.com --timeout 90 -e /usr/share/openstack-tripleo-heat-templates/environments/puppet-pacemaker.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml -e ceph.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e network-environment.yaml --ceph-storage-scale 3 --control-flavor control --compute-flavor compute --ceph-storage-flavor ceph-storage



[stack@undercloud ~]$ cat ceph.yaml
parameter_defaults:
  ExtraConfig:
    ceph::profile::params::osds:
        '/dev/sdb': {}
        '/dev/sdc': {}
        '/dev/sdd': {}


[stack@undercloud ~]$ grep -A1 resource_registry /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml
resource_registry:
  OS::TripleO::NodeUserData: /home/stack/wipe-disk.yaml


[stack@undercloud ~]$ cat wipe-disk.yaml
heat_template_version: 2014-10-16

description: >
  Wipe and convert all disks to GPT (except the disk containing the root file system)

resources:
  userdata:
    type: OS::Heat::MultipartMime
    properties:
      parts:
      - config: {get_resource: wipe_disk}

  wipe_disk:
    type: OS::Heat::SoftwareConfig
    properties:
      config: {get_file: /home/stack/wipe-disk.sh}

outputs:
  OS::stack_id:
    value: {get_resource: userdata}


Result:

Removing the current plan files           
Uploading new plan files                  
Started Mistral Workflow. Execution ID: 06e91441-d9be-49cf-b52e-a3df3b70b99e
Plan updated                                                                
Deploying templates in the directory /usr/share/openstack-tripleo-heat-templates
Started Mistral Workflow. Execution ID: d210979c-ce25-4b20-bc2e-cc1e3fe93d4b    
{u'execution': {u'id': u'd210979c-ce25-4b20-bc2e-cc1e3fe93d4b',                 
                u'input': {u'container': u'overcloud',                          
                           u'queue_name': u'6c6c0528-f784-4021-a671-5a7fcd59fdf6',
                           u'timeout': 90},                                       
                u'name': u'tripleo.deployment.v1.deploy_plan',                    
                u'params': {},                                                    
                u'spec': {u'input': [u'container',                                
                                     {u'timeout': 240},                           
                                     {u'queue_name': u'tripleo'}],                
                          u'name': u'deploy_plan',                                
                          u'tasks': {u'copy_validation_ssh_keys': {u'name': u'copy_validation_ssh_keys',
                                                                   u'on-complete': u'send_message',     
                                                                   u'type': u'direct',                  
                                                                   u'version': u'2.0',                  
                                                                   u'workflow': u'tripleo.validations.v1.copy_ssh_key'},
                                     u'deploy': {u'action': u'tripleo.deployment.deploy timeout=<% $.timeout %> container=<% $.container %>',
                                                 u'name': u'deploy',                                                                         
                                                 u'on-error': u'set_deployment_failed',                                                      
                                                 u'on-success': u'test_validations_enabled',                                                 
                                                 u'type': u'direct',                                                                         
                                                 u'version': u'2.0'},                                                                        
                                     u'send_message': {u'action': u'zaqar.queue_post',                                                       
                                                       u'input': {u'messages': {u'body': {u'payload': {u'execution': u'<% execution() %>',   
                                                                                                       u'message': u"<% $.get('message', '') %>",
                                                                                                       u'status': u"<% $.get('status', 'SUCCESS') %>"},
                                                                                          u'type': u'tripleo.deployment.v1.deploy_plan'}},             
                                                                  u'queue_name': u'<% $.queue_name %>'},                                               
                                                       u'name': u'send_message',                                                                       
                                                       u'retry': u'count=5 delay=1',                                                                   
                                                       u'type': u'direct',                                                                             
                                                       u'version': u'2.0'},                                                                            
                                     u'set_deployment_failed': {u'name': u'set_deployment_failed',                                                     
                                                                u'on-success': u'send_message',                                                        
                                                                u'publish': {u'message': u'<% task(deploy).result %>',                                 
                                                                             u'status': u'FAILED'},                                                    
                                                                u'type': u'direct',                                                                    
                                                                u'version': u'2.0'},                                                                   
                                     u'test_validations_enabled': {u'action': u'tripleo.validations.enabled',                                          
                                                                   u'name': u'test_validations_enabled',                                               
                                                                   u'on-error': u'send_message',                                                       
                                                                   u'on-success': u'copy_validation_ssh_keys',                                         
                                                                   u'type': u'direct',                                                                 
                                                                   u'version': u'2.0'}},                                                               
                          u'version': u'2.0'}},                                                                                                        
 u'message': u"No connection adapters were found for 'file:///home/stack/wipe-disk.sh'",                                                               
 u'status': u'FAILED'}  



Expected result:
The overcloud deployment should proceed.

Comment 1 Alexander Chuzhoy 2016-10-14 20:17:19 UTC

*** This bug has been marked as a duplicate of bug 1380902 ***


Note You need to log in before you can comment on or make changes to this bug.