Bug 138523 - PC hangs after loading "ehci-hcd" kernel module with USB devices connected
PC hangs after loading "ehci-hcd" kernel module with USB devices connected
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-09 14:16 EST by Sven Neuhaus
Modified: 2015-01-04 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-10 17:24:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sven Neuhaus 2004-11-09 14:16:06 EST
Description of problem:

I upgraded from FC2 to FC3. At first boot of FC3, i get
...
udev starten: [OK]
Initialisiehre Hardware... Speicher Netzwerk Audio

then the machine hangs.

I modified /etc/rc.d/rc.sysinit to display the kernel modules that are
being loaded.
The machine hangs after loading the "ehci-hcd" module. 

(hangs = no output on console when pressing keys on the keyboard)

I have not upgraded any packages after installation yet.

Hardware:
Athlon 2500+ 
1 GB RAM
ASRock K7S8X mainboard
Maverick Gigabit Ethernet PCI
Soundblaster Live! PCI
Comment 1 Sven Neuhaus 2004-11-09 16:13:58 EST
I noticed the PC no longer hangs when I remove the Logitech USB mouse.
more about the mouse:
M/N: M-BJ69
P/N: 830667-0000

Workaround: connect the mouse to the PS/2 port with the mechanical
adapter included with the mouse.

Note: I had the same problem with FC2 but only during installation, it
worked fine after that.
Comment 2 Sebastian Marten 2004-11-10 14:26:33 EST
I have the same problem, aber the installation the system hangs at the
first boot.

I've allsow connectet my Logitech mouse to the PS/2 Port but the
system did not start.

Any other solutions?
Comment 3 Sven Neuhaus 2004-11-10 16:40:14 EST
try adding the option "nousb" to the kernel options in grub (with "e")
Comment 4 Sebastian Marten 2004-11-11 10:31:51 EST
No it was another problem, i removed "rhgb" from the grup.conf an the
system boots.

It seembs to be a problem with my nvidia card 
Comment 5 Sven Neuhaus 2004-11-14 05:21:01 EST
The PC also hangs when I connect a USB 2.0 9-in-1 card reader when the
ehci-hcd module is loaded.

Here's the "lspci" output:
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 746 Host (rev 02)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SG86C202
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS963 [MuTIOL
Media IO] (rev 25)
00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0
Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0
Controller (rev 0f)
00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 2.0
Controller
00:0c.0 Ethernet controller: Marvell Technology Group Ltd. Yukon
Gigabit Ethernet 10/100/1000Base-T Adapter (rev 12)
00:0d.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1
(rev 05)
00:0d.1 Input device controller: Creative Labs SB Live! MIDI/Game Port
(rev 05)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R350
[Radeon 9800 Pro]
01:00.1 Display controller: ATI Technologies Inc Radeon R350 [Radeon
9800 Pro] (Secondary)


The PC doesn't hang when I unload the ehci-hcd kernel module and only
the ohci-hcd module is loaded. Alas, transfer are slow then (USB 1.1
speeds).
USB 2.0 worked (at USB 2.0 speeds) with the same mainboard (ASRock
K7S8X) with Fedora Core 2.
Comment 6 John Rosauer 2004-11-15 07:01:36 EST
I get random hanging after the module uhci_hcd is loaded and while
the module ehci-hcd is loaded.

I tracked it down to this by adding debug to /etc/rc.sysinit.

Furthermore, I have worked around the problem by adding a
"sleep 1" before each module is loaded (in the function load_module).

Therefore, given I experience the problem unreliably, and only
the addition of a delay "fixes", I propose it is a race condition
in one of the two USB driver modules.
Comment 7 John Rosauer 2004-11-16 03:11:42 EST
Opps, I should have said:

I get random hanging just after the module ehci_hcd is loaded, while
the module uhci-hcd is loaded.

sorry.

Nevertheless, a "sleep 1" after module ehci_hcd "fixes" the problem.
Comment 8 Need Real Name 2004-11-24 16:34:53 EST
I, too

"get random hanging just after the module ehci_hcd is loaded,
while the module uhci-hcd is load[ing]"

It seems to happen right here:

[USB buses get registered, then]
kernel: input: USB HID v1.10 Mouse [Logitech Trackball] on
usb-0000:00:1d.1-1
kernel: uhci_hcd 0000:00:1d.1: host system error, PCI problems?
kernel: uhci_hcd 0000:00:1d.1: host controller process error,
something bad happened!
localhost kernel: uhci_hcd 0000:00:1d.1: host controller halted, very bad!

Noting comment#1 I moved the trackball to serial using an adaptor, but
since the problem had been random can't be sure this is a genuine
workaround.

Hadn't noticed this at all with FC2 (though, again, randomness can
fool one).
Comment 9 Dave Jones 2005-07-15 13:34:04 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 10 Sven Neuhaus 2005-07-16 15:01:05 EDT
I have upgraded to FC4 shortly after release, but all kernels released so far
(including kernel-2.6.12-1.1398_FC4) have not fixed the problem.

I posted a more detailed USB device configuration at
http://www.mail-archive.com/linux-usb-users@lists.sourceforge.net/msg12420.html

Basically, when ehci-hcd is loaded, the machine hangs unless no USB devices are
connected.
Comment 11 Sven Neuhaus 2005-07-22 05:09:08 EDT
I haven't yet tried putting a delay between module loads as suggested by John
Rosauer, will do it tonight.
Comment 12 Sven Neuhaus 2005-09-10 04:04:37 EDT
Update:

For me, adding a 1 second delay did not solve the problem. The computer still
hangs every time.

Also, the problem still occurs with kernel-2.6.12-1.1447_FC4.

I have mailed linux-usb-users in the past but got no response, any idea what
else I can do to help get this working again?
Comment 13 Jan Visser 2005-09-21 02:27:48 EDT
I have the same problem, except that it resumes booting eventually.

Here is some information about my laptop (HP Pavilion zv5450EA):

http://solid.bounceme.net/pub_files/bootproblem/sysinfo.txt

http://solid.bounceme.net/pub_files/bootproblem/bootchart-without-usb.png
http://solid.bounceme.net/pub_files/bootproblem/bootchart-with-usb.png
Comment 14 Dave Jones 2005-09-30 02:05:07 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 15 Jan Visser 2005-10-03 16:44:22 EDT
I updated to the newest kernel but it still hangs at boot. Too bad :P
Comment 16 Sven Neuhaus 2005-10-05 13:48:25 EDT
The problems is still there, even with kernel-2.6.13-1.1526_FC4
Comment 17 Jan Visser 2005-10-21 12:09:17 EDT
And with kernel-2.6.13-1.1532_FC4 it's there too.
Comment 18 Sven Neuhaus 2005-10-22 11:27:09 EDT
Same for me.

Jan, could you post the output of your "lspci -v" here?
Comment 19 Jan Visser 2005-10-24 10:29:47 EDT
hold on, here it comes: 
[root@pc843 ~]# lspci -v
00:00.0 Host bridge: nVidia Corporation nForce3 Host Bridge (rev a4)
        Flags: bus master, 66Mhz, fast devsel, latency 0
        Memory at e8000000 (32-bit, prefetchable) [size=128M]
        Capabilities: [44] HyperTransport: Slave or Primary Interface
        Capabilities: [c0] AGP version 2.0

00:01.0 ISA bridge: nVidia Corporation nForce3 LPC Bridge (rev a6)
        Subsystem: nVidia Corporation: Unknown device 0c80
        Flags: bus master, 66Mhz, fast devsel, latency 0

00:01.1 SMBus: nVidia Corporation nForce3 SMBus (rev a4)
        Subsystem: Hewlett-Packard Company: Unknown device 006d
        Flags: 66Mhz, fast devsel, IRQ 10
        I/O ports at 2040 [size=64]
        I/O ports at 2000 [size=64]
        Capabilities: [44] Power Management version 2

00:02.0 USB Controller: nVidia Corporation nForce3 USB 1.1 (rev a5) (prog-if 10
[OHCI])
        Subsystem: nVidia Corporation: Unknown device 0c80
        Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 11
        Memory at e0000000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [44] Power Management version 2

00:02.1 USB Controller: nVidia Corporation nForce3 USB 1.1 (rev a5) (prog-if 10
[OHCI])
        Subsystem: nVidia Corporation: Unknown device 0c80
        Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 10
        Memory at e0001000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [44] Power Management version 2

00:02.2 USB Controller: nVidia Corporation nForce3 USB 2.0 (rev a2) (prog-if 20
[EHCI])
        Subsystem: nVidia Corporation: Unknown device 0c80
        Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 10
        Memory at e0004000 (32-bit, non-prefetchable) [size=256]
        Capabilities: [80] Power Management version 2

00:06.0 Multimedia audio controller: nVidia Corporation nForce3 Audio (rev a2)
        Subsystem: Hewlett-Packard Company: Unknown device 006d
        Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 11
        I/O ports at 1400 [size=256]
        I/O ports at 1c00 [size=128]
        Memory at e0002000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [44] Power Management version 2

00:06.1 Modem: nVidia Corporation: Unknown device 00d9 (rev a2) (prog-if 00
[Generic])
        Subsystem: Hewlett-Packard Company: Unknown device 006d
        Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 10
        I/O ports at 1800 [size=256]
        I/O ports at 1c80 [size=128]
        Memory at e0003000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [44] Power Management version 2

00:08.0 IDE interface: nVidia Corporation nForce3 IDE (rev a5) (prog-if 8a
[Master SecP PriP])
        Subsystem: nVidia Corporation: Unknown device 0c80
        Flags: bus master, 66Mhz, fast devsel, latency 0
        I/O ports at 2080 [size=16]
        Capabilities: [44] Power Management version 2

00:0a.0 PCI bridge: nVidia Corporation nForce3 PCI Bridge (rev a2) (prog-if 00
[Normal decode])
        Flags: bus master, 66Mhz, fast devsel, latency 0
        Bus: primary=00, secondary=02, subordinate=0a, sec-latency=128
        I/O behind bridge: 00003000-00007fff
        Memory behind bridge: e0100000-e17fffff
        Prefetchable memory behind bridge: 20000000-23ffffff

00:0b.0 PCI bridge: nVidia Corporation nForce3 AGP Bridge (rev a4) (prog-if 00
[Normal decode])
        Flags: bus master, 66Mhz, medium devsel, latency 16
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=10
        Memory behind bridge: e2000000-e2ffffff
        Prefetchable memory behind bridge: f0000000-f80fffff

00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
HyperTransport Technology Configuration
        Flags: fast devsel
        Capabilities: [80] HyperTransport: Host or Secondary Interface

00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
        Flags: fast devsel

00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM
Controller
        Flags: fast devsel

00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Miscellaneous Control
        Flags: fast devsel

01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 420 Go 32M]
(rev a3) (prog-if 00 [VGA])
        Subsystem: Hewlett-Packard Company: Unknown device 006d
        Flags: bus master, 66Mhz, medium devsel, latency 248, IRQ 11
        Memory at e2000000 (32-bit, non-prefetchable) [size=16M]
        Memory at f0000000 (32-bit, prefetchable) [size=128M]
        Memory at f8000000 (32-bit, prefetchable) [size=512K]
        [virtual] Expansion ROM at f8080000 [disabled] [size=128K]
        Capabilities: [60] Power Management version 2
        Capabilities: [44] AGP version 2.0

02:00.0 FireWire (IEEE 1394): Texas Instruments TSB43AB21 IEEE-1394a-2000
Controller (PHY/Link) (prog-if 10 [OHCI])
        Subsystem: Hewlett-Packard Company: Unknown device 006d
        Flags: bus master, medium devsel, latency 64, IRQ 11
        Memory at e0108000 (32-bit, non-prefetchable) [size=2K]
        Memory at e0100000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [44] Power Management version 2

02:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
        Subsystem: Realtek Semiconductor Co., Ltd. RT8139
        Flags: bus master, medium devsel, latency 64, IRQ 10
        I/O ports at 7000 [size=256]
        Memory at e0108800 (32-bit, non-prefetchable) [size=256]
        Capabilities: [50] Power Management version 2

02:02.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN
Controller (rev 03)
        Subsystem: Hewlett-Packard Company: Unknown device 12fa
        Flags: bus master, fast devsel, latency 64, IRQ 11
        Memory at e0104000 (32-bit, non-prefetchable) [size=8K]

02:04.0 CardBus bridge: Texas Instruments PCI1620 PC Card Controller (rev 01)
        Subsystem: Hewlett-Packard Company: Unknown device 006d
        Flags: bus master, medium devsel, latency 168, IRQ 11
        Memory at e0106000 (32-bit, non-prefetchable) [size=4K]
        Bus: primary=02, secondary=03, subordinate=06, sec-latency=176
        Memory window 0: 20000000-21fff000 (prefetchable)
        Memory window 1: e0400000-e07ff000
        I/O window 0: 00003000-00003fff
        I/O window 1: 00004000-00004fff
        16-bit legacy interface ports at 0001

02:04.1 CardBus bridge: Texas Instruments PCI1620 PC Card Controller (rev 01)
        Subsystem: Hewlett-Packard Company: Unknown device 006d
        Flags: bus master, medium devsel, latency 168, IRQ 10
        Memory at e0107000 (32-bit, non-prefetchable) [size=4K]
        Bus: primary=02, secondary=07, subordinate=0a, sec-latency=176
        Memory window 0: 22000000-23fff000 (prefetchable)
        Memory window 1: e0c00000-e0fff000
        I/O window 0: 00005000-00005fff
        I/O window 1: 00006000-00006fff
        16-bit legacy interface ports at 0001

02:04.2 System peripheral: Texas Instruments PCI1620 Firmware Loading Function
(rev 01)
        Subsystem: Hewlett-Packard Company: Unknown device 006d
        Flags: bus master, medium devsel, latency 64
        I/O ports at 7400 [size=64]
        Capabilities: [44] Power Management version 2
Comment 20 Jan Visser 2005-10-24 10:31:53 EDT
I just noticed an even stranger details. If I temporarily insert my USB mouse
for a few seconds before udev comes by, it still freezes at the same point.
Comment 21 Dave Jones 2005-11-10 14:01:02 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 22 Sven Neuhaus 2005-11-10 16:02:35 EST
Bug is still present in 2.6.14-1.1637_FC4, unfortunately. Computer locks up
after ehci-hcd module is loaded.
Comment 23 Sven Neuhaus 2005-11-10 17:24:48 EST
I found a fix for my particular problem: I flashed the latest BIOS (v2.60). 
Loading ehci-hcd no longer makes the PC hang and I can use USB 2.0 devices at
high speed.
None of the BIOS release notes for the ASRock K7S8X that were newer than the one
I was using mention any USB fixes, so I didn't bother trying this earlier until
I read somewhere on the net that it solved someone else's USB problems, too.

Note You need to log in before you can comment on or make changes to this bug.