Bug 138546 - Power Save features kick in even if computer is in use
Power Save features kick in even if computer is in use
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xscreensaver (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-09 15:36 EST by Matthew Mott
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-27 18:29:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Mott 2004-11-09 15:36:40 EST
Description of problem:
Power Save functionality of xscreensaver appears to take no account of
keyboard/mouse usage, and activates after its set delay even while the
computer is in use.

Version-Release number of selected component (if applicable):
xscreensaver-4.14-5

How reproducible:
Always

Steps to Reproduce:
1. In Fedora 2 Gnome menu, select Preferences then Screensaver
2. On the Advanced tab, enable "Power Management Enabled" and enter a
delay of 20 minutes for the Suspend mode and zeroes for the other two
modes.
3. Continue to use the computer until the delay has elapsed.
  
Actual results:
The monitor will blank after 20 minutes, even if a keypress or mouse
movement has been made very recently. If another keypress or mouse
movement is made, the screen will re-appear for another delay period.
Interaction during the delay period does not seem to reset the timer.

Expected results:
The screen should blank after the delay period only if no keyboard or
mouse activity is registered. If such activity is detected the timer
should reset to zero.

Additional info:
If this problem is caused by the use of zero delays in the other two
boxes (apart from suspend), then this is a user interface issue rather
than a timer issue, but a bug nonetheless.
Tested with two different monitors (Dell 17-inch CRT and Dell
UltraScan 19-inch flatpanel).
Comment 1 Matthew Mott 2004-11-21 16:28:54 EST
Update: I have used FC 3 for quite a while with power features enabled, and have
not yet seen this issue. It is not possible to determine whether this is caused
by differing levels of keyboard/mouse activity, or whether the bug has been fixed.
Comment 2 Warren Togami 2004-11-27 18:29:20 EST
This is not enough information to diagnose the problem.  In any case
closing because you are unable to reproduce it now.
Comment 3 Matthew Mott 2004-11-28 06:58:18 EST
Looking at my settings, I think it may have been the use of 0 values
that is confusing the xscreensaver program. I am now using 15/16/17
minutes which seems to work fine. Perhaps the interface should make
clear that "0" does NOT mean "never".

Note You need to log in before you can comment on or make changes to this bug.