Bug 1385694 (CVE-2016-8678) - CVE-2016-8678 ImageMagick: Heap-buffer overflow in IsPixelMonochrome
Summary: CVE-2016-8678 ImageMagick: Heap-buffer overflow in IsPixelMonochrome
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2016-8678
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,public=20161007,repor...
Depends On: 1381145
Blocks: 1381146
TreeView+ depends on / blocked
 
Reported: 2016-10-17 14:01 UTC by Andrej Nemec
Modified: 2019-06-08 21:31 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-20 08:29:00 UTC


Attachments (Terms of Use)

Description Andrej Nemec 2016-10-17 14:01:34 UTC
A heap-buffer overflow vulnerability was found in ImageMagick in pixel-accessor.h.

References:

http://seclists.org/oss-sec/2016/q4/67
https://blogs.gentoo.org/ago/2016/10/07/imagemagick-heap-based-buffer-overflow-in-ispixelmonochrome-pixel-accessor-h/

Comment 1 Andrej Nemec 2016-10-20 08:11:07 UTC
Created ImageMagick tracking bugs for this issue:

Affects: fedora-all [bug 1381145]

Comment 2 Adam Mariš 2016-12-09 08:15:46 UTC
Upstream bug:

https://github.com/ImageMagick/ImageMagick/issues/272

Upstream had problems with reproducing the issue. Closed later as Q64 issue, which is not supported.


Note You need to log in before you can comment on or make changes to this bug.