Bug 138581 - Please replace xmms with bmp (beep-media-player)
Please replace xmms with bmp (beep-media-player)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xmms (Show other bugs)
3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-09 18:41 EST by Richard Hughes
Modified: 2013-03-13 00:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-25 10:59:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Hughes 2004-11-09 18:41:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
BMP is a multimedia player that currently uses a skinned user
interface based on Winamp 2.x skins. It is based on XMMS.

XMMS is a GTK1 application and looks very out of place on the gnome
desktop. 

BMP is a GTK2 port of XMMS that uses the same WinAmp skins with a
mostly unchanged user experience. 

Version-Release number of selected component (if applicable):
xmms-1.2.10-9

How reproducible:
Always

Steps to Reproduce:
1. Install FC3
2. Run xmms
3. Be horrified at the GTK1 engine and how it looks different to all
the other *new* stuff.

Actual Results:  Saw a GTK1 interface which I knew how to use
Expected Results:  Saw a GTK2 interface which I knew how to use

Additional info:
http://www.sosdg.org/~larne/w/BMP_Homepage
http://www.sosdg.org/~larne/w/Screenshots

Also, bmp decouples the mp3 plugin from the application, so no worries
about patching to remove MP3.
Comment 1 Philip Van Hoof 2004-11-15 15:06:23 EST
BeepMP with the Bluecurve theme and some font-settings configured in a
way that it looks like a default xmms setup.

http://www.freax.be/files/beepmp-screenshot.png
Comment 2 Colin Walters 2004-12-14 16:45:48 EST
Why not just use e.g. totem or HelixPlayer instead?
Comment 3 Richard Hughes 2004-12-19 06:07:59 EST
Totem is in my mind for video, the playlist is wrong for lots of
files, and it's too big. I want something (of a few pixels) to dock in
the top right of my window. HelixPlayer isn't too bad but suffers the
same problems as totem - it's too generic. I want an WinAMP style
player (which I've used for 5+ years on windows, and then 5+ years on
linux) that I'm comfortable with. I'm sure lots of users will agree.
bmp seems almost like an "update" to xmms (with GTK2, but not many
other changes), and when everything else is GTK2 is seems a shame not
to make the transistion.
Comment 4 Colin Walters 2004-12-20 09:57:35 EST
Can you elaborate on how the playlist is wrong for lots of files?

As for the size - what if we added a music control to the panel?
Comment 5 Richard Hughes 2004-12-20 15:36:53 EST
A panel control would be an excellent idea. I don't like the idea of
switching to a whole new window just to click >> on totem.

Perhaps if totem was to show the playlist automatically when I run an
m3u/pls file that would be a step in the right direction... It's
unlikly by playing a m3u file I want to listen to the album one song
at a time, for every song. Finding the option for "show playlist"
takes two more clicks than I want.
Comment 6 Mephisto 2005-01-07 05:21:54 EST
I would personally stick to XMMS until they finally put the Queue
button back in the jump-to dialog. i dont like to cut a track in the
middle, and prefer the player to complete the current track before
playing the next one, so the queue function is one of my most appreciated.
also, the jump-to in BMP is painfully slow with a lot of files on the
playlist (i often have more then 5000 on it), while XMMS is lightning
fast with resorting the list, no matter how many files there are. i
have also some other issues with BMP, but they are fairly small
compared to this one (like skinning issues on the playlist and some
plugins).
until they fix these issues, i stick with XMMS, and I wouldnt
recommend switching to a player that hasnt even left beta stage to be
included as a replacement to a player that just works. i would love to
see XMMS upgraded to GTK2, cause you are right, GTK1 sure looks
outdated, but BMP just isnt ready yet.
Comment 7 Lee, Eunho 2005-02-24 12:24:25 EST
I'm korean. Sorry my poor english.
I can't see xmms.
because, xmms can't display korean. such "사랑"
and also can't display chinese or japanese. such "爱" or "あい"
xmms builded GTK1. So don't support UTF-8.
bmp(beep-media-player) builded GTK2.
The player support UTF-8.
So I agree. And many asian agree this idea.
Comment 8 Mike Sowka 2005-07-23 18:08:34 EDT
I second the notion of getting bmp into the main stream.

Mike
Comment 9 John (J5) Palmieri 2005-07-25 10:59:51 EDT
xmms has move to extras.  Closing this bug.  If you want to see bmp get into
extras the best way is to become a maintainer for it or find somone who is
willing to do it.

Note You need to log in before you can comment on or make changes to this bug.