Bug 138610 - star: Tar file too small (amount: 0 bytes).
star: Tar file too small (amount: 0 bytes).
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: star (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-10 03:33 EST by Andre Robatino
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-16 03:57:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2004-11-10 03:33:06 EST
Description of problem:
  When extracting a directory from a large tarfile, the error

star: Tar file too small (amount: 0 bytes).
star: Unexpected EOF on input.
star: Cannot recover from error - exiting.

appears.  The extracted directory appears correct (except the last
file and top-level directory don't have their modification times set
back) so I think this is a completely spurious error.

Version-Release number of selected component (if applicable):
star-1.5a25-6

How reproducible:
not sure (only attempted once)

Steps to Reproduce:
1.  Run command of the form "star zxvf archive.tgz directory".
  
Actual results:
  Correct output with above spurious error message.

Expected results:
  Correct output without error message.

Additional info:
  Archive was originally created using star (from FC2).
Comment 1 Peter Vrabec 2004-11-15 08:40:50 EST
I can not reproduce this bug.
What was the size of tarfile and extracted directory?
Comment 2 Andre Robatino 2004-11-15 12:37:32 EST
  The size was roughly 500 MB.  I am also unable to reproduce the bug
now with the tarfile.  Is it possible that it was generated by the
udev flakiness that affected the CDROM device before the initial udev
update was applied (since this happened just after a clean install,
probably before I had a chance to apply the updates)?
Comment 3 Andre Robatino 2004-11-15 12:50:42 EST
  Sorry, forgot to mention that the .tgz file was on a CDROM.

Note You need to log in before you can comment on or make changes to this bug.