Bug 138615 - The gimp's print dialog should pick up cups' share options
The gimp's print dialog should pick up cups' share options
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gimp-print (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-10 04:35 EST by Sitsofe Wheeler
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-13 08:54:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sitsofe Wheeler 2004-11-10 04:35:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040804 Galeon/1.3.17

Description of problem:
By default, when printing from the gimp to a CUPS broadcast added
share, raw postscript text appears out of the printer rather than the
picture intended.

Version-Release number of selected component (if applicable):
gimp-2.0.5-5
gimp-print-4.2.7-2

How reproducible:
Always

Steps to Reproduce:
1. Set up a CUPS broadcast share on another machine.
2. On intended machine check that printer was automatically picked up
 by looking at /var/log/cups/error_log
3. Start the gimp.
4. Open a picture and then go to File -> Print...
5. Choose the print button.

Actual Results:  Postscript text appears out of the printer.

Expected Results:  Single page picture to appear out of the printer.

Additional info:

Within the print dialog, going to Setup Printer... and removing -oraw
(despite the tooltip's dire warnings about doing so) from the Command
text box fixes the problem and a picture is printed.

I suspect that this is all down to a lack of integration between
gimp-print and CUPS because various configured options on the CUPS
share are wrong within the gimp's print dialog. Other programs like
gpdf print correctly and default their page size to A4 whereas the
gimp's print dialog sets the page size to be letter.

This is a big problem because eog (gnome's default image viewer) does
not allow the printing of pictures and users often end up firing up
the gimp to print only to wind up wasting paper and causing a mess.

I have just noticed bug 73053 ... This is nearly the same other than
my request for gimp-print CUPS integration in the same way that gdpf's
print dialog was able to do.
Comment 1 Tim Waugh 2004-12-02 12:23:56 EST
I'm sort of hoping that 5.0 will do a lot better here.  There is certainly
plenty of opportunity for having things "just work" where they currently don't.
Comment 2 Sitsofe Wheeler 2005-10-20 18:51:06 EDT
This has persisted into Fedora Core 4...
Comment 3 Sitsofe Wheeler 2006-05-26 11:17:47 EDT
Woohoo! This appears fixed in FC5...
Comment 4 Tim Waugh 2006-05-26 11:29:58 EDT
Er.. really?
Comment 5 Sitsofe Wheeler 2006-05-27 03:30:56 EDT
Ah, no not really. You got me Tim!

The main complaint has been solved: printing from the GIMP to a broadcast share
no longer needs -oraw to be removed and the printer correctly displays picture
rather than postscript. Perhaps CUPS has become better at detecting Postscript
or when the queue was made a different option was ticked.

However the GIMP print dialog still doesn't pick up the broadcast share's print
options (which is what this bug is now about).

I'm going to change the version to FC5 but perhaps it should be set to devel
since this bug has been around so long...
Comment 6 Chris Jones 2007-02-26 06:43:19 EST
With the upgrade to FC6 the main problem seems -oraw problem seems to have
resurfaced.. this is a complete pain as our users just panic when the printer
wont stop printing. By the time somebody who knows whats going on gets involved
it its printed junk on most of a ream of paper.

Is there anyway we can work around this bug untill its fixed?
Comment 7 Sitsofe Wheeler 2007-02-26 16:45:16 EST
Changing version to fc6 (perhaps it should be set to devel?)
Comment 8 Tim Waugh 2007-03-13 08:54:31 EDT
This is fixed in F-7 with the transition to gutenprint-plugin.

Note You need to log in before you can comment on or make changes to this bug.