Bug 1386205 - spamassassin-3.4.1-10.fc26 FTBFS: Cannot use SSL; libraries or header files are missing.
Summary: spamassassin-3.4.1-10.fc26 FTBFS: Cannot use SSL; libraries or header files a...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: spamassassin
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL: https://apps.fedoraproject.org/kosche...
Whiteboard:
Depends On:
Blocks: 1383740
TreeView+ depends on / blocked
 
Reported: 2016-10-18 12:09 UTC by Petr Pisar
Modified: 2016-11-06 21:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-06 21:49:49 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
SpamAssassin 7361 0 None None None 2016-10-24 20:22:34 UTC

Description Petr Pisar 2016-10-18 12:09:19 UTC
spamassassin-3.4.1-10.fc26 fails to build in F26:

checking for CRYPTO_lock in -lcrypto... no
checking for SSL_CTX_free in -lssl... yes
configure: error: Cannot use SSL; libraries or header files are missing.

This is caused by upgrading openssl from 1:1.0.2j-1.fc26 to 1:1.1.0b-1.fc26.

Comment 1 Kevin Fenzi 2016-10-24 20:22:35 UTC
Filed upstream as https://bz.apache.org/SpamAssassin/show_bug.cgi?id=7361

Comment 2 Kevin Fenzi 2016-11-06 21:49:49 UTC
Added patch from upstream, built in rawhide.


Note You need to log in before you can comment on or make changes to this bug.