Bug 1386255 - NetApp Cinder driver: cloning operations are unsuccessful
Summary: NetApp Cinder driver: cloning operations are unsuccessful
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 10.0 (Newton)
Assignee: Eric Harney
QA Contact: lkuchlan
URL:
Whiteboard:
Depends On: 1370012 1386253 1386268
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-18 13:45 UTC by Eric Harney
Modified: 2017-07-27 06:57 UTC (History)
11 users (show)

Fixed In Version: openstack-cinder-9.0.0-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1386253
Environment:
Last Closed: 2016-12-14 16:21:51 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 386041 None None None 2016-10-18 13:45:47 UTC
Launchpad 1608596 None None None 2016-10-18 13:45:47 UTC
Red Hat Knowledge Base (Solution) 2644511 None None None 2016-10-18 13:45:47 UTC

Description Eric Harney 2016-10-18 13:45:47 UTC
+++ This bug was initially created as a clone of Bug #1386253 +++

+++ This bug was initially created as a clone of Bug #1370012 +++

Description of problem:
Cinder cloning operations are unsuccessful when using the cinder NetApp driver

Version-Release number of selected component (if applicable):
openstack-cinder-2014.2.4-6.el7ost.noarch

How reproducible:
Very often (10% of the time),  cinder cloning operations are unsuccessful

Steps to Reproduce:
1.
2.
3.

Actual results:



--- Additional comment from Eric Harney on 2016-10-13 11:45:31 EDT ---

I've submitted a new patch upstream which I think may be an easier workaround.  It will be waiting for review from NetApp engineers.

https://review.openstack.org/#/c/386041/

Comment 3 lkuchlan 2016-11-27 14:44:49 UTC
Tested using:
openstack-cinder-9.0.0-12.el7ost.noarch

Verification flow:

[stack@undercloud-0 ~]$ cinder list
+--------------------------------------+-----------+------+------+-------------+----------+-------------+
| ID                                   | Status    | Name | Size | Volume Type | Bootable | Attached to |
+--------------------------------------+-----------+------+------+-------------+----------+-------------+
| 88026bc7-c2f3-4703-b533-b1b8d590fff0 | available | -    | 1    | -           | false    |             |
+--------------------------------------+-----------+------+------+-------------+----------+-------------+

[stack@undercloud-0 ~]$ cinder show 88026bc7-c2f3-4703-b533-b1b8d590fff0
+--------------------------------+----------------------------------------------------------+
| Property                       | Value                                                    |
+--------------------------------+----------------------------------------------------------+
| attachments                    | []                                                       |
| availability_zone              | nova                                                     |
| bootable                       | false                                                    |
| consistencygroup_id            | None                                                     |
| created_at                     | 2016-11-27T14:34:52.000000                               |
| description                    | None                                                     |
| encrypted                      | False                                                    |
| id                             | 88026bc7-c2f3-4703-b533-b1b8d590fff0                     |
| metadata                       | {}                                                       |
| migration_status               | None                                                     |
| multiattach                    | False                                                    |
| name                           | None                                                     |
| os-vol-host-attr:host          | hostgroup@Netapp-nfs1#10.35.64.11:/vol/vol_rhos_auto_nfs |
| os-vol-mig-status-attr:migstat | None                                                     |
| os-vol-mig-status-attr:name_id | None                                                     |
| os-vol-tenant-attr:tenant_id   | 99c6e8b4171543f1aa6593180e325904                         |
| replication_status             | disabled                                                 |
| size                           | 1                                                        |
| snapshot_id                    | None                                                     |
| source_volid                   | None                                                     |
| status                         | available                                                |
| updated_at                     | 2016-11-27T14:34:54.000000                               |
| user_id                        | 874a5ec46d2c4e3fa3d5cca7ca145456                         |
| volume_type                    | None                                                     |
+--------------------------------+----------------------------------------------------------+

[stack@undercloud-0 ~]$ cinder list
+--------------------------------------+-----------+------+------+-------------+----------+-------------+
| ID                                   | Status    | Name | Size | Volume Type | Bootable | Attached to |
+--------------------------------------+-----------+------+------+-------------+----------+-------------+
| 88026bc7-c2f3-4703-b533-b1b8d590fff0 | available | -    | 1    | -           | false    |             |
+--------------------------------------+-----------+------+------+-------------+----------+-------------+

[stack@undercloud-0 ~]$ cinder create 1 --source-volid 88026bc7-c2f3-4703-b533-b1b8d590fff0
+--------------------------------+----------------------------------------------------------+
| Property                       | Value                                                    |
+--------------------------------+----------------------------------------------------------+
| attachments                    | []                                                       |
| availability_zone              | nova                                                     |
| bootable                       | false                                                    |
| consistencygroup_id            | None                                                     |
| created_at                     | 2016-11-27T14:37:04.000000                               |
| description                    | None                                                     |
| encrypted                      | False                                                    |
| id                             | a5fb3384-3560-44db-912d-33634eb80514                     |
| metadata                       | {}                                                       |
| migration_status               | None                                                     |
| multiattach                    | False                                                    |
| name                           | None                                                     |
| os-vol-host-attr:host          | hostgroup@Netapp-nfs1#10.35.64.11:/vol/vol_rhos_auto_nfs |
| os-vol-mig-status-attr:migstat | None                                                     |
| os-vol-mig-status-attr:name_id | None                                                     |
| os-vol-tenant-attr:tenant_id   | 99c6e8b4171543f1aa6593180e325904                         |
| replication_status             | disabled                                                 |
| size                           | 1                                                        |
| snapshot_id                    | None                                                     |
| source_volid                   | 88026bc7-c2f3-4703-b533-b1b8d590fff0                     |
| status                         | creating                                                 |
| updated_at                     | 2016-11-27T14:37:05.000000                               |
| user_id                        | 874a5ec46d2c4e3fa3d5cca7ca145456                         |
| volume_type                    | None                                                     |
+--------------------------------+----------------------------------------------------------+

[stack@undercloud-0 ~]$ cinder list
+--------------------------------------+-----------+------+------+-------------+----------+-------------+
| ID                                   | Status    | Name | Size | Volume Type | Bootable | Attached to |
+--------------------------------------+-----------+------+------+-------------+----------+-------------+
| 88026bc7-c2f3-4703-b533-b1b8d590fff0 | available | -    | 1    | -           | false    |             |
| a5fb3384-3560-44db-912d-33634eb80514 | available | -    | 1    | -           | false    |             |
+--------------------------------------+-----------+------+------+-------------+----------+-------------+

[stack@undercloud-0 ~]$ cinder create 1 --image-id 032dfca8-183b-496b-9ce1-f8708ed14a3b
+--------------------------------+----------------------------------------------------------+
| Property                       | Value                                                    |
+--------------------------------+----------------------------------------------------------+
| attachments                    | []                                                       |
| availability_zone              | nova                                                     |
| bootable                       | false                                                    |
| consistencygroup_id            | None                                                     |
| created_at                     | 2016-11-27T14:39:00.000000                               |
| description                    | None                                                     |
| encrypted                      | False                                                    |
| id                             | 417ecc25-481d-4982-a786-aee36afe9d9e                     |
| metadata                       | {}                                                       |
| migration_status               | None                                                     |
| multiattach                    | False                                                    |
| name                           | None                                                     |
| os-vol-host-attr:host          | hostgroup@Netapp-nfs1#10.35.64.11:/vol/vol_rhos_auto_nfs |
| os-vol-mig-status-attr:migstat | None                                                     |
| os-vol-mig-status-attr:name_id | None                                                     |
| os-vol-tenant-attr:tenant_id   | 99c6e8b4171543f1aa6593180e325904                         |
| replication_status             | disabled                                                 |
| size                           | 1                                                        |
| snapshot_id                    | None                                                     |
| source_volid                   | None                                                     |
| status                         | creating                                                 |
| updated_at                     | 2016-11-27T14:39:01.000000                               |
| user_id                        | 874a5ec46d2c4e3fa3d5cca7ca145456                         |
| volume_type                    | None                                                     |
+--------------------------------+----------------------------------------------------------+

[stack@undercloud-0 ~]$ cinder list
+--------------------------------------+-------------+------+------+-------------+----------+-------------+
| ID                                   | Status      | Name | Size | Volume Type | Bootable | Attached to |
+--------------------------------------+-------------+------+------+-------------+----------+-------------+
| 417ecc25-481d-4982-a786-aee36afe9d9e | downloading | -    | 1    | -           | false    |             |
| 88026bc7-c2f3-4703-b533-b1b8d590fff0 | available   | -    | 1    | -           | false    |             |
| a5fb3384-3560-44db-912d-33634eb80514 | available   | -    | 1    | -           | false    |             |
+--------------------------------------+-------------+------+------+-------------+----------+-------------+

[stack@undercloud-0 ~]$ cinder list
+--------------------------------------+-----------+------+------+-------------+----------+-------------+
| ID                                   | Status    | Name | Size | Volume Type | Bootable | Attached to |
+--------------------------------------+-----------+------+------+-------------+----------+-------------+
| 417ecc25-481d-4982-a786-aee36afe9d9e | available | -    | 1    | -           | true     |             |
| 88026bc7-c2f3-4703-b533-b1b8d590fff0 | available | -    | 1    | -           | false    |             |
| a5fb3384-3560-44db-912d-33634eb80514 | available | -    | 1    | -           | false    |             |
+--------------------------------------+-----------+------+------+-------------+----------+-------------+

Comment 5 errata-xmlrpc 2016-12-14 16:21:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.