Bug 138638 - memprof doesn't show function names
memprof doesn't show function names
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: memprof (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-10 08:32 EST by David Juran
Modified: 2014-06-18 05:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-07 22:20:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test program (470 bytes, text/plain)
2004-11-10 08:33 EST, David Juran
no flags Details

  None (edit)
Description David Juran 2004-11-10 08:32:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20040924

Description of problem:
Attached is a simple program that leaks memory. compile it with 
gcc -g -omemtest memtest.c

Now when I run memprof on one computer is corretly shows the functions
in which the leaks are occuring like 

Function:         Self:        Total:
----------------- ------------ ---------------
__libc_malloc                0            3000
__libc_start_main            0           18000
_start                       0           18000
f                         3000            6000
fgh                          0           12000
g                         8000            8000
h                         4000            4000
main                         0           18000
malloc_hook_ini           3000            3000
----------------------------------------------

Now when I run it on another identical machine I instead get  only the 
__libc_malloc
__libc_start_main
malloc_hook_ini
entries and under the 'leaks' tab I get a lot of (???) as function name.

The strange thing is that this is not reproducable very well. If I
open up a different session on the same computer where it didn't work
before, it suddenly may work. I don't really know how to debug this
any further so I submit it here in case anyone would have any ideas
inspite of this somewhat confusing report (-:

Version-Release number of selected component (if applicable):
memprof-0.5.1-3

How reproducible:
Sometimes

Steps to Reproduce:
1. ???
 

Additional info:
Comment 1 David Juran 2004-11-10 08:33:32 EST
Created attachment 106410 [details]
test program

Note You need to log in before you can comment on or make changes to this bug.