This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 138649 - Tamil characters have spacing problem (overlapping glyphs)
Tamil characters have spacing problem (overlapping glyphs)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
: i18n
Depends On:
Blocks: Indic 137149
  Show dependency treegraph
 
Reported: 2004-11-10 09:57 EST by Jatin Nansi
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: openoffice.org-1.1.2-18.6.EL4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-21 02:02:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
test case for tamil spacing bug (5.22 KB, application/octet-stream)
2004-11-10 09:59 EST, Jatin Nansi
no flags Details
screenshot of OOo displaying the bug (120.35 KB, image/png)
2004-11-10 10:01 EST, Jatin Nansi
no flags Details
Test screenshot after hacking out transformation array application (184.37 KB, image/png)
2004-12-02 11:49 EST, Dan Williams
no flags Details

  None (edit)
Description Jatin Nansi 2004-11-10 09:57:36 EST
Description of problem:
Certain specific tamil characters overlap over each other. This
appears to be a spacing bug. 

Version-Release number of selected component (if applicable):
1.1.2-10

How reproducible:
Everytime

Steps to Reproduce:
1. LANG=ta_IN.UTF-8 oowriter
2. Open the attached .sxw
3. Copy and paste the contents into gedit
  
Actual results:
Several characters overlap
Characters do not overlap in gedit

Expected results:
Characters should not overlap

Additional info:
It looks like overlapping happens only in case of 2 specific characters. 
This bug so far only appears in tamil
Comment 1 Jatin Nansi 2004-11-10 09:59:21 EST
Created attachment 106416 [details]
test case for tamil spacing  bug
Comment 2 Jatin Nansi 2004-11-10 10:01:28 EST
Created attachment 106417 [details]
screenshot of OOo displaying the bug
Comment 3 Dan Williams 2004-12-02 11:48:46 EST
Can you check the attached screenshot for errors?  I haven't found
what exactly is causing the issue, but it appears that OOo is applying
a transformation array to the string causing the glyphs to be
overlapped.  When the transformation array is not applied, I get the
attached screenshot.  I still need to figure out what's creating the
transformation array and why.
Comment 4 Dan Williams 2004-12-02 11:49:43 EST
Created attachment 107772 [details]
Test screenshot after hacking out transformation array application
Comment 5 Dan Williams 2004-12-02 17:19:27 EST
I believe I have a patch for this bug, will incorporate fix into
1.1.2-15.  There still seem to be problems with character deletion and
selection though (the strings don't decompose into the correct
sequence when you delete one glyph).
Comment 6 Dan Williams 2004-12-06 21:10:01 EST
A partial fix that makes this much better should show up in 1.1.2-15
and later builds.
Comment 7 Dan Williams 2004-12-07 22:55:47 EST
Look for 1.1.2-16.6.EL4 in dist-4E-scratch and please test against
this build.
Comment 8 Jatin Nansi 2004-12-08 09:17:37 EST
This bug is fixed in 1.1.2-16.6.EL4. Leaving bug status at modified.
will change this to resolved after the fixed pkg is built into RHEL4.
Comment 9 Akira TAGOH 2004-12-10 13:11:26 EST
It looks good on even 1.1.2-17.6.EL4.
Comment 10 Lawrence Lim 2005-02-21 02:02:20 EST
Confirmed fixed. Tested with openoffice.org-1.1.2-18.6.EL4.


Thanks.

Note You need to log in before you can comment on or make changes to this bug.