Bug 1386629 - No connection adapters were found for ....
Summary: No connection adapters were found for ....
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 10.0 (Newton)
Assignee: RHOS Maint
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-19 10:31 UTC by Matthias Runge
Modified: 2016-12-14 16:22 UTC (History)
6 users (show)

Fixed In Version: python-tripleoclient-5.3.0-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:22:24 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 385456 None None None 2016-10-19 13:07:35 UTC
Launchpad 1631426 None None None 2016-10-19 10:35:00 UTC

Description Matthias Runge 2016-10-19 10:31:08 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Matthias Runge 2016-10-19 10:35:01 UTC
Please merge the fix for https://bugs.launchpad.net/tripleo/+bug/1631426 downstream as well. It currently prevents deploying logging or monitoring environment.

With replaced tripleoclient from trunk.rdoproject.org deployment works.


Full trace of the error:

openstack overcloud deploy --templates /usr/share/openstack-tripleo-heat-templates --libvirt-type kvm --control-flavor oooq_control --compute-flavor oooq_compute --ceph-storage-flavor oooq_ceph --timeout 90 -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/net-single-nic-with-vlans.yaml -e /home/stack/network-environment.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/low-memory-usage.yaml --neutron-network-type vxlan --neutron-tunnel-types vxlan --ntp-server pool.ntp.org -e /usr/share/openstack-tripleo-heat-templates/environments/logging-environment.yaml -e logging.yaml
Removing the current plan files
Uploading new plan files
Started Mistral Workflow. Execution ID: a6491706-4c8b-41d1-a0a4-00c11b0ac5b7
Plan updated
Deploying templates in the directory /tmp/tripleoclient-nNESQH/tripleo-heat-templates
Started Mistral Workflow. Execution ID: a7944458-3863-4aee-8ce5-1a48f79cd351
{u'execution': {u'id': u'a7944458-3863-4aee-8ce5-1a48f79cd351',
                u'input': {u'container': u'overcloud',
                           u'queue_name': u'021487cd-ef5b-47a6-9575-fa20e184b7ed',
                           u'timeout': 90},
                u'name': u'tripleo.deployment.v1.deploy_plan',
                u'params': {},
                u'spec': {u'input': [u'container',
                                     {u'timeout': 240},
                                     {u'queue_name': u'tripleo'}],
                          u'name': u'deploy_plan',
                          u'tasks': {u'copy_validation_ssh_keys': {u'name': u'copy_validation_ssh_keys',
                                                                   u'on-complete': u'send_message',
                                                                   u'type': u'direct',
                                                                   u'version': u'2.0',
                                                                   u'workflow': u'tripleo.validations.v1.copy_ssh_key'},
                                     u'deploy': {u'action': u'tripleo.deployment.deploy timeout=<% $.timeout %> container=<% $.container %>',
                                                 u'name': u'deploy',
                                                 u'on-error': u'set_deployment_failed',
                                                 u'on-success': u'test_validations_enabled',
                                                 u'type': u'direct',
                                                 u'version': u'2.0'},
                                     u'send_message': {u'action': u'zaqar.queue_post',
                                                       u'input': {u'messages': {u'body': {u'payload': {u'execution': u'<% execution() %>',
                                                                                                       u'message': u"<% $.get('message', '') %>",
                                                                                                       u'status': u"<% $.get('status', 'SUCCESS') %>"},
                                                                                          u'type': u'tripleo.deployment.v1.deploy_plan'}},
                                                                  u'queue_name': u'<% $.queue_name %>'},
                                                       u'name': u'send_message',
                                                       u'retry': u'count=5 delay=1',
                                                       u'type': u'direct',
                                                       u'version': u'2.0'},
                                     u'set_deployment_failed': {u'name': u'set_deployment_failed',
                                                                u'on-success': u'send_message',
                                                                u'publish': {u'message': u'<% task(deploy).result %>',
                                                                             u'status': u'FAILED'},
                                                                u'type': u'direct',
                                                                u'version': u'2.0'},
                                     u'test_validations_enabled': {u'action': u'tripleo.validations.enabled',
                                                                   u'name': u'test_validations_enabled',
                                                                   u'on-error': u'send_message',
                                                                   u'on-success': u'copy_validation_ssh_keys',
                                                                   u'type': u'direct',
                                                                   u'version': u'2.0'}},
                          u'version': u'2.0'}},
 u'message': u"No connection adapters were found for 'file:///usr/share/openstack-tripleo-heat-templates/puppet/services/logging/fluentd-base.yaml'",
 u'status': u'FAILED'}
+ true
+ heat stack-list
+ grep -q CREATE_FAILED
WARNING (shell) "heat stack-list" is deprecated, please use "openstack stack list" instead
 
 
with logging.yaml being:
resource_registry:
  OS::TripleO::Services::FluentdClient: /usr/share/openstack-tripleo-heat-templates/puppet/services/logging/fluentd-client.yaml
 
parameter_defaults:
 
  LoggingServers:
   - host: 192.168.36.83
     port: 4000

Comment 4 Leonid Natapov 2016-11-17 12:50:52 UTC
tested with python-tripleoclient-5.3.0-7.el7ost.noarch

Availability Monitoring and Centralized Logging can be successfully installed.

Comment 6 errata-xmlrpc 2016-12-14 16:22:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.