Bug 1386829 - Tempest skips all neutron tests when ironic_inspector plugin is installed
Summary: Tempest skips all neutron tests when ironic_inspector plugin is installed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic-inspector
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 10.0 (Newton)
Assignee: Dmitry Tantsur
QA Contact: Sergii Nozhka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-19 16:52 UTC by Gabriel Szasz
Modified: 2016-12-14 16:23 UTC (History)
9 users (show)

Fixed In Version: openstack-ironic-inspector-4.2.0-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:23:02 UTC


Attachments (Terms of Use)
Output of the "tools/runtests.sh '.*neutron.*'" command. (2.94 KB, application/x-gzip)
2016-10-19 16:52 UTC, Gabriel Szasz
no flags Details
Verification output of the "tools/runtests.sh '.*neutron.*'" command. (4.78 KB, application/x-gzip)
2016-11-02 09:15 UTC, Sergii Nozhka
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 387403 None None None 2016-10-20 09:16:07 UTC

Description Gabriel Szasz 2016-10-19 16:52:43 UTC
Created attachment 1212227 [details]
Output of the "tools/runtests.sh '.*neutron.*'" command.

Description of problem:
Tempest skips all neutron tests when the ironic_inspector tempest plugin is installed.

Version-Release number of selected component (if applicable):
12.2.1-0.20161004111913.ef2befe.1.el7ost

How reproducible:
100%

Steps to Reproduce:

  1. Deploy OpenStack into the virtual environment, e.g. using OSPD-Customized-Deployment Jenkins script [1]
  2. Log into the undercloud node.
  3. Convince yourself whether openstack-tempest package is installed.
  4. Convince yourself whether external public network is created in overcloud.
  5. Convince yourself whether tempest-deployer-input.conf was created by OSP-d.
  6. Create tempest directory and cd into the directory.
  7. source ~/overcloudrc
  8. Run: tools/config_tempest.py \
--deployer-input ~/tempest-deployer-input.conf \
--debug --create identity.uri $OS_AUTH_URL \
identity.admin_password $OS_PASSWORD \
--network-id <OVERCLOUD_PUBLIC_NETWORK_ID>
  9. Install all Tempest plugins
     sudo yum install -y openstack-packstack-all
 10. Convince yourself that neutron service is enabled in etc/tempest.conf
 11. Run: tools/run-tests.sh '.*neutron.*'

[1] https://rhos-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/OSPD-Customized-Deployment/

 
Actual results:

The neutron tests are skipped with message

"SKIPPED: Neutron support is required"

(See attachment for output)

Expected results:

The neutron tests should be executed properly.

Additional info:
The file /usr/lib/python2.7/site-packages/ironic_inspector/test/inspector_tempest_plugin/plugin.py contains following lines 

38. # FIXME(dtantsur): pretend like Neutron does not exist due to random
39. # failures, see https://bugs.launchpad.net/bugs/1621791.
40. cfg.CONF.set_override('neutron', False, 'service_available')

It means that it this particular plugin overrides config file value for neutron to False for whole Tempest.

Comment 1 Arx Cruz 2016-10-19 16:58:51 UTC
Upstream doesn't seems to see this failures, because they don't run this test with Ironic installed. We do because we have different setup's and one of them has both Ironic inspector and Neutron.

Comment 2 Daniel Mellado 2016-10-19 18:56:48 UTC
Please *do* assign this to ironic inspector. This has *nothing* to do with tempest core code.

Comment 3 Dmitry Tantsur 2016-10-20 09:16:08 UTC
Danial, it's not entirely correct, we are working around deficient SSH code in tempest.lib in this situation. However, I do realize that we have to unbreak people before we continue investigating the root cause.

Comment 4 Dmitry Tantsur 2016-10-20 09:17:05 UTC
(sorry for typo in your name)

Comment 5 Daniel Mellado 2016-10-20 09:18:56 UTC
Hey Dmitry, that makes sense to me and I'm more than willing to help on that if you need some extra manpower, my answer was meaning to move the bug to ironic-inspector for now at least. As RHOP doesn't use grenade the upstream bug shouldn't apply at all there, IMHO, so we could even remove those lines in the packaging if needed, wdyt?

Thanks!

Comment 6 Dmitry Tantsur 2016-10-20 09:26:05 UTC
Yeah, I agree that we should work around it for now, then try to fix for real. I hope that the attached patch will fix it for you without breaking us. Otherwise, we can always get back to patching the package.

Comment 10 Sergii Nozhka 2016-11-02 09:15:56 UTC
Created attachment 1216408 [details]
Verification output of the "tools/runtests.sh '.*neutron.*'" command.

Comment 11 Sergii Nozhka 2016-11-02 09:17:47 UTC
The issue not reproduced with openstack-ironic-inspector-4.2.0-2.el7ost.noarch.
Please refer attachment 1216408 [details] for details.

Comment 13 errata-xmlrpc 2016-12-14 16:23:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.