This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 138685 - gcc miscompiles numerical code (lapack)
gcc miscompiles numerical code (lapack)
Status: CLOSED DUPLICATE of bug 138683
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
3
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-10 13:05 EST by Dmitri A. Sergatskov
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-10 17:39:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dmitri A. Sergatskov 2004-11-10 13:05:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
It appears that gcc in FC3 miscompiles numerical code. 
The problem appears to be with lapack libraries and can be
demonstrated with octave (which uses them):

[dima@localhost ~]$ octave
GNU Octave, version 2.1.57 (i686-pc-linux-gnu).
Copyright (C) 2004 John W. Eaton.
....

octave:1> a=rand(100);
octave:2> tic; eig(a); toc
error: dgeev failed to converge
octave:2>
---------------
Sometimes it just hangs there for few minutes after which I kill it.
I tried to compile octave myseelf agains ATLAS (different, optimized
blas/lapack implementation) libraries, which I compile myself as well.
The result was the same. I also tried different versions of octave.

This al works on RHEL3, RH9, FC2, FC1. 

It is possible that the problem is actually with glibc. I was not able
to recompile octave with gcc33 to check that.


Version-Release number of selected component (if applicable):
gcc version 3.4.2 20041017 (Red Hat 3.4.2-6.fc3)

How reproducible:
Always

Steps to Reproduce:
1. start octave
2. type at the octave prompt as shown
3.
    

Actual Results:  octave hangs or gives an error 

Expected Results:  "0.004" (may vary slightly) -- this is 4 msec that
it took the code to run on FC2.

Additional info:

this is on athlon/xp 2000MHz/500Meg.
Comment 1 Jakub Jelinek 2004-11-10 17:39:26 EST

*** This bug has been marked as a duplicate of 138683 ***

Note You need to log in before you can comment on or make changes to this bug.