Bug 138692 - yum (and up2date) fail after updating python
yum (and up2date) fail after updating python
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-10 13:56 EST by Pete Lancashire
Modified: 2014-01-21 17:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-10 14:17:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Lancashire 2004-11-10 13:56:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
finally did a yum update with *python* not in my exclude list.

but now yum and up2date fail

yum -y update

Traceback (most recent call last):  
File "/usr/bin/yum", line 6, in ?    
import yummain  
File "/usr/share/yum-cli/yummain.py", line 23, in ?    
import yum  
File "/usr/lib/python2.4/site-packages/yum/__init__.py", 
line 20, in ?    import rpmImportError: No module named rpm

up2date

Traceback (most recent call last): 
File "/usr/sbin/up2date", line 11, in ?    
import rpmImportError: No module named rpm

Version-Release number of selected component (if applicable):
yum-2.1.11-4 up2date-4.3.53-3 python-2.4-0.b2.3

How reproducible:
Always

Steps to Reproduce:
1. yum -y update or up2date

    

Actual Results:  yum -y update

Traceback (most recent call last):  
File "/usr/bin/yum", line 6, in ?    
import yummain  
File "/usr/share/yum-cli/yummain.py", line 23, in ?    
import yum  
File "/usr/lib/python2.4/site-packages/yum/__init__.py", 
line 20, in ?    import rpmImportError: No module named rpm

up2date

Traceback (most recent call last): 
File "/usr/sbin/up2date", line 11, in ?    
import rpmImportError: No module named rpm

Additional info:

ouch !!!!
Comment 1 Seth Vidal 2004-11-10 14:17:29 EST
did you intend to use rawhide/development?

if not, then reinstall.

if so, then, well, this is what happens.

Comment 2 Pete Lancashire 2004-11-10 14:29:12 EST
yes i intended to use dev

please don't assume that someone didnt want to use dev

it is a bug, but is a dup of 138535, i do apologize for that.
or should 138535 be closed as not being a bug as well ?

and yes this is what happens, but isn't this what bugzilla is for ?

please let me know, and I'll stop 
Comment 3 Seth Vidal 2004-11-10 14:31:27 EST
okay but this is definitely not a bug in yum or up2date.

it's a bug in the python or rpm-python packages.


Note You need to log in before you can comment on or make changes to this bug.