Bug 138694 - Evolution freezes/crashes when migrating data from 1.4 to 2.0.2-3
Evolution freezes/crashes when migrating data from 1.4 to 2.0.2-3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-10 14:02 EST by Alejandro Gonzalez Hernandez - Imoq
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 2.0.4-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-28 12:43:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alejandro Gonzalez Hernandez - Imoq 2004-11-10 14:02:48 EST
Description of problem:

System upgraded from Fedora Core 2 to Fedora Core 3, keeping /home
partition with evolution files in ~/evolution. After started for the
first time, Evolution asked to migrate data (about 240 MB, mostly IMAP
accounts plus contacts, calendar and some tasks) and after a while it
freezed. I waited some hours but didn't come back. Trying to re-run
evolution freezed at the same point. Then I realized that a
~/.evolution file was made, so I renamed ~/evolution to
~/evolution.old so it didn't try to migrate. Evolution then started
correctly but my contacts/calendar/tasks where no migrated.

I found some bugs related to this in Evolution's bugzilla, at:

http://bugzilla.ximian.com./buglist.cgi?product=Evolution&version=2.0.2&email1=&emailtype1=substring&emailassigned_to1=1&email2=&emailtype2=substring&emailreporter2=1&changedin=&chfieldfrom=&chfieldto=Now&chfieldvalue=&short_desc=migrat&short_desc_type=substring&long_desc=&long_desc_type=substring&bug_file_loc=&bug_file_loc_type=substring&keywords=&keywords_type=anywords&op_sys_details=&op_sys_details_type=substring&version_details=&version_details_type=substring&cmdtype=doit&order=%27Importance%27&form_name=query

There seems to be a patch on this thread:

http://bugzilla.ximian.com./show_bug.cgi?id=68787

that seems to solve this bug (?), so I request it to be applied.

The direct URL for the patch is:

http://bugzilla.ximian.com./showattachment.cgi?attach_id=13125
Comment 1 Alejandro Gonzalez Hernandez - Imoq 2005-02-28 12:42:52 EST
I used the new evolution test packages:

evolution-2.0.4-1.i386.rpm
evolution-data-server-1.0.4-3.i386.rpm
libgal2-2.2.5-1.i386.rpm
libsoup-2.2.2-1.FC3.i386.rpm

Used my OLD evolution/ directory and the migration finally worked :)

Now I have my calendar and my contacts again. I am happy.
Comment 2 Dave Malcolm 2005-02-28 13:33:24 EST
Thanks for the feedback!

Note You need to log in before you can comment on or make changes to this bug.