Bug 138721 - http hangs when trying connect to www.f5.com
Summary: http hangs when trying connect to www.f5.com
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-10 21:02 UTC by Osmo Laitinen
Modified: 2015-01-04 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-23 20:36:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Osmo Laitinen 2004-11-10 21:02:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
When trying connect directly (without any proxy) to http://www.f5.com
connection "hangs", there is no data. Tried with several browsers and
telnet program.

Example:
uname -a
Linux lossi 2.6.8-1.521

[ossi@lossi ~]$ telnet www.f5.com 80
Trying 205.229.151.213...
Connected to www.f5.com.
Escape character is '^]'.
GET / HTTP/1.0
 


Version-Release number of selected component (if applicable):
kernel-2.6.7-1.494.2.2, kernel-2.6.8-1.521

How reproducible:
Always

Steps to Reproduce:
1. telnet www.f5.com 80
2. GET / HTTP/1.0 (press enter)
3. (press enter)
    

Actual Results:  Nothing. Connection is made, but then things stops.


Expected Results:  Get the data of "index page".

Additional info:

Everything seems to be working fine with kernel 2.6.6 and earlier.
Also 2.6.9 kernel seems to work fine.

Comment 1 Dave Jones 2004-11-20 06:55:18 UTC
fixed in latest errata kernel ?


Comment 2 Osmo Laitinen 2004-11-23 20:36:55 UTC
Tested with latest kernel (2.6.9-1.6_FC2) and 2.6.7-1.494.2.2 and
2.6.8-1.521.

Now all of those works ok in this situation.
The case was tested with a few other people (and with Debian using
2.6.8 kernel) and they had same problem.
Wonder what might have caused it...



Note You need to log in before you can comment on or make changes to this bug.