Bug 1387216 - [geo-rep]: [Errno 16] Device or resource busy: '/tmp/gsyncd-aux-mount-5BA95I'
Summary: [geo-rep]: [Errno 16] Device or resource busy: '/tmp/gsyncd-aux-mount-5BA95I'
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Aravinda VK
QA Contact:
URL:
Whiteboard:
Depends On: 1338693
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-20 11:21 UTC by Aravinda VK
Modified: 2018-08-29 03:35 UTC (History)
5 users (show)

Fixed In Version: glusterfs-4.1.3 (or later)
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1338693
Environment:
Last Closed: 2018-08-29 03:35:51 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Aravinda VK 2016-10-20 11:21:10 UTC
+++ This bug was initially created as a clone of Bug #1338693 +++

Description of problem:
=======================

Following traceback on aux-mount is observed during geo-rep sanity cases which does fops create,chmod,chown,chgrp,symlink,hardlink,truncate,rename and rmdir. This is most likely during rmdir. 

[2016-05-22 17:45:05.458262] E [resource(/bricks/brick0/master_brick2):1292:inhibit] <top>: mount cleanup failure:
Traceback (most recent call last):
  File "/usr/libexec/glusterfs/python/syncdaemon/resource.py", line 1290, in inhibit
    self.cleanup_mntpt(mntpt)
  File "/usr/libexec/glusterfs/python/syncdaemon/resource.py", line 1316, in cleanup_mntpt
    os.rmdir(mntpt)
OSError: [Errno 16] Device or resource busy: '/tmp/gsyncd-aux-mount-G3GogE'
[2016-05-22 17:45:05.460496] E [resource(/bricks/brick1/master_brick8):1292:inhibit] <top>: mount cleanup failure:
Traceback (most recent call last):
  File "/usr/libexec/glusterfs/python/syncdaemon/resource.py", line 1290, in inhibit
    self.cleanup_mntpt(mntpt)
  File "/usr/libexec/glusterfs/python/syncdaemon/resource.py", line 1316, in cleanup_mntpt
    os.rmdir(mntpt)
OSError: [Errno 16] Device or resource busy: '/tmp/gsyncd-aux-mount-5BA95I'



How reproducible:
=================
1/2


Steps Carried:
==============

Found during automation cases of geo-rep {tarssh+fuse}

Comment 1 Worker Ant 2016-10-20 11:22:34 UTC
REVIEW: http://review.gluster.org/15686 (geo-rep: Prevent worker crash if aux mount cleanup fails) posted (#1) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 2 Amar Tumballi 2018-08-29 03:35:51 UTC
This update is done in bulk based on the state of the patch and the time since last activity. If the issue is still seen, please reopen the bug.


Note You need to log in before you can comment on or make changes to this bug.