Bug 1387246 - Update via "baremetal import" fails when some of the existing nodes are in not in "enroll" or "available" state, e.g.: The requested action "manage" can not be performed on node "..." while it is in state "manageable"
Summary: Update via "baremetal import" fails when some of the existing nodes are in no...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: 10.0 (Newton)
Assignee: Dmitry Tantsur
QA Contact: Sergii Nozhka
URL:
Whiteboard:
: 1386764 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-20 12:38 UTC by Dmitry Tantsur
Modified: 2016-12-14 16:23 UTC (History)
6 users (show)

Fixed In Version: openstack-tripleo-common-5.3.0-4.el7ost python-tripleoclient-5.3.0-7.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:23:25 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 394429 None None None 2016-11-08 16:50:44 UTC
OpenStack gerrit 394930 None None None 2016-11-08 16:50:21 UTC
Launchpad 1635240 None None None 2016-10-20 12:38:35 UTC

Description Dmitry Tantsur 2016-10-20 12:38:36 UTC
Our workflows expect all nodes to be in these states and thus to accept "manage" action. This is not correct, e.g. when some nodes are deployed to or are in manageable state. We need to only apply "manage" action to nodes in "enroll" state.

Comment 1 Dmitry Tantsur 2016-10-21 08:41:42 UTC
*** Bug 1386764 has been marked as a duplicate of this bug. ***

Comment 4 Sergii Nozhka 2016-11-15 16:38:49 UTC
The issue not reproduced with openstack-tripleo-common-5.3.0-6.el7ost.noarch

Comment 7 errata-xmlrpc 2016-12-14 16:23:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.