Bug 1387290 - Events are not available in API and central.log complains about redis
Summary: Events are not available in API and central.log complains about redis
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ceilometer
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 10.0 (Newton)
Assignee: Eoghan Glynn
QA Contact: Yurii Prokulevych
URL:
Whiteboard:
Depends On: 1391860
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-20 14:38 UTC by Marek Aufart
Modified: 2016-12-14 16:23 UTC (History)
6 users (show)

Fixed In Version: openstack-ceilometer-7.0.0-2.2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:23:37 UTC


Attachments (Terms of Use)
central.log (3.47 KB, text/plain)
2016-10-20 14:38 UTC, Marek Aufart
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC

Description Marek Aufart 2016-10-20 14:38:32 UTC
Created attachment 1212552 [details]
central.log

Description of problem:
Events list return no events (when there should be some) and /var/log/central.log on controller node contains following errors:

ERROR ceilometer.coordination ToozConnectionError: Error while reading from socket: ('Connection closed by server.',)

Discussed with @pradk, who pointed me to issue with redis. I am not sure if it was fixed already, but I was not able to find such BZ and my current testing version has this issue.


Version-Release number of selected component (if applicable):
7.0.1-0.20161015232718

How reproducible:
always (in given version)

Steps to Reproduce:
1. deploy overcloud
2. create flavor or do another action which produces an event (openstack volume create --size 1 testvol)
3. query ceilometer for events

Actual results:
no events, errors in central.log

Expected results:
get some events, no errors in /var/log/ceilometer/central.log

Additional info:
Workaround is to connect to controller node and do following steps:
# mkdir /var/run/redis
# chown redis /var/run/redis
# systemctl start redis

Comment 1 Mehdi ABAAKOUK 2016-10-20 16:56:43 UTC
Today, I have deployed a couple of time OSP 10.0-20161018.1.el7ost and I haven't seen this. 
I have tested the gnocchi metric computing dispatch that uses redis to spread the work across workers and everything was working fine.

Comment 2 Pradeep Kilambi 2016-10-20 17:21:59 UTC
There was an selinux issue that was causing redis to not start correctly. This has been fixed in openstack-selinux. So i think this should be resolved in latest build.

Comment 6 errata-xmlrpc 2016-12-14 16:23:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.