Bug 1387302 - pacemaker stonith-property is set always to false despite pre-upgrade status
Summary: pacemaker stonith-property is set always to false despite pre-upgrade status
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: 10.0 (Newton)
Assignee: Michele Baldessari
QA Contact: Marian Krcmarik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-20 15:03 UTC by Marian Krcmarik
Modified: 2016-12-14 16:23 UTC (History)
5 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.0.0-1.2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:23:45 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 391056 None None None 2016-10-28 09:31:01 UTC
Launchpad 1635294 None None None 2016-10-20 15:03:54 UTC

Description Marian Krcmarik 2016-10-20 15:03:55 UTC
Description of problem:
The pacemaker stonith-property is set to false after an upgrade from RHOS9 to RHOS10 even though it was set to true before upgrade - This causes fencing to be disable so fencing of overcloud nodes does not work properly especially in split-brain condition

Version-Release number of selected component (if applicable):
puppet-tripleo-5.2.0-2.el7ost.noarch
openstack-tripleo-common-5.2.1-0.20161007114757.cc19d04.el7ost.noarch
openstack-tripleo-heat-templates-5.0.0-0.20161008015357.0d3e3e3.1.el7ost.noarch
openstack-tripleo-puppet-elements-5.0.0-0.20161003213431.200d011.el7ost.noarch
python-tripleoclient-5.2.0-2.el7ost.noarch
openstack-tripleo-image-elements-5.0.0-1.el7ost.noarch
openstack-tripleo-0.0.8-0.2.4de13b3git.el7ost.noarch
openstack-tripleo-heat-templates-compat-2.0.0-34.3.el7ost.noarch
openstack-tripleo-ui-1.0.3-1.el7ost.noarch

How reproducible:
Always (presumably), The condition seems to be racy.

Steps to Reproduce:
1. Deploy RHOS9 - set stonith-enabled to true (pcs property set stonith-enabled=true)
2. Upgrade to RHOS10

Actual results:
stonith-enabled is false

Expected results:
stonith-enabled should keep the state - true

Additional info:

Comment 1 Michele Baldessari 2016-10-20 18:20:19 UTC
Marian, could you give the attached gerrit patch a spin and report back please? Thanks

Comment 2 Marian Krcmarik 2016-10-21 14:09:37 UTC
(In reply to Michele Baldessari from comment #1)
> Marian, could you give the attached gerrit patch a spin and report back
> please? Thanks

I tried to perform "major upgrade step" with patched major_upgrade_controller_pacemaker_1.sh and It seems to work correctly, even though I did perform only the major upgrade step, I was watching tje status of stonith-enabled property and could verify that It was switched to false and then again properly switched to true and kept that way.

Comment 3 Michele Baldessari 2016-10-28 09:31:02 UTC
Stable/newton change has merged

Comment 6 errata-xmlrpc 2016-12-14 16:23:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.