Bug 138748 - Grub can't make it to boot menu with SATA drive
Grub can't make it to boot menu with SATA drive
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-10 18:24 EST by Mason Glaves
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 17:17:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mason Glaves 2004-11-10 18:24:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
Basically I tried BOTH an upgrade from FC2 and a completely
freshinstall of FC3, and what follows is equally true:

*  Installed Fedora Core 3 on a system that is known to have been
working with Fedora Core 2.

*  Upgrade went perfectly fine, but noticed that the SATA hard disk
was now located at /dev/sda instead of /dev/hdg

*  Reboot.  Bad Joss, Grub gets to stage 2 and reports "GRUB Hard Disk
Error"

*  Rescue disk mounts everything just fine.

*  Try again with a complete reinstall instead of upgrade, result the
same.

Version-Release number of selected component (if applicable):
v.95, I think

How reproducible:
Always

Steps to Reproduce:
1.  Install fc2
2.  upgrade
3.  fail on first boot

or

1. install fc3
2. fail on first boot.
    

Actual Results:  "GRUB Hard Disk Error" after stage2 message

Expected Results:  Grub menu at least

Additional info:

I tried putting an IDE drive in and installing just on that, but same
result.  I only suspect SATA is the core of the problem becuase I read
other people mention this same problem on SATA drives.  Plan to try
the same thing again by installing fc2 and trlling it not to touch the
boot loader when it upgrades.
Comment 1 Mikko Mikkola 2004-11-11 04:04:25 EST
I see something similar. I had a new machine (AMD64, Promise 378 SATA
RAID) with no previous OS. Everything went fine until the first boot -
all I get is the GRUB command line. It is possible to boot the system
by specifying the kernel, initrd etc. on command line, but I don't
know GRUB well enough (yet) to make it automatic.
Comment 2 Mason Glaves 2004-11-11 08:33:51 EST
If I use the grub from FC2, I can get the install to work just fine. 
All I have to do is install FC2, minimal, with a tiny boot partition,
then install FC3, full install, but tell it to use NO BOOTLOADER. 
Then when reboot, grub works fine.  Manually point it to the right
boot partition the first time (FC3 boot partition), then when finished
installing, mount the FC2 boot bartition and edit grub.conf to
permanantly point to FC3.  

I may experiement some more to see what else I can get it to do in the
future, but for now at least it's booting.  What changed in grub
between fc2 and fc3?  anything really major?
Comment 3 Jeremy Katz 2004-11-11 13:42:29 EST
The change from grub 0.94 -> 0.95 was pretty small from what I
remember and it was mostly adding things to the second stage and not
adjustements that would change this.  Could you check if there is a
BIOS update available for your machine?
Comment 4 John Thacker 2006-10-30 17:17:36 EST
Closing per lack of response to previous request for information.
This bug was originally filed against a much earlier version of Fedora
Core, and significant changes have taken place since the last version
for which this bug is confirmed.

Note that FC3 and FC4 are supported by Fedora Legacy for security
fixes only.  Please install a still supported version and retest.  If
it still occurs on FC5 or FC6, please reopen and assign to the correct
version.  Otherwise, if this a security issue, please change the
product to Fedora Legacy.  Thanks, and we are sorry that we did not
get to this bug earlier.

Note You need to log in before you can comment on or make changes to this bug.