This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 138751 - kernel-sourcecode rpm missing from fc3
kernel-sourcecode rpm missing from fc3
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-10 18:32 EST by Chris Petersen
Modified: 2015-01-04 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-10 18:45:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Petersen 2004-11-10 18:32:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020 Galeon/1.3.18

Description of problem:

I've read on some mailing lists that the kernel-sourcecode rpm was
removed from fc3 "because you can build new kernels from the
src.rpm"...  Well, that's not the point of the sourcecode rpm -- the
sourcecode rpm is there so we can build modules against the kernel
source.  The src.rpm has NONE of the patches applied, and doesn't
install to /usr/src/linux.

Now, it seems that it might be possible to `rpmbuild --rebuild` the
src.rpm and get it to produce a sourcecode rpm, but there is no i386
option, and x86_64 doesn't seem to build on my dev box (to then be
ported over to some itaniums that we're testing kernel modules on). 
So even the "you can build new kernels from the src.rpm" argument is
wrong since I obviously can't just build new kernels, I can only build
for my current architecture (i686 -- which redhat has typically
ignored in favor of putting "-march pentium4" under i386, but that's a
whole other issue).

Please fix this.  It's a broken policy.  There should be no need to
force people to wait for an entire kernel to compile just to get at
the kernel-sourcecode rpm.

Version-Release number of selected component (if applicable):
Comment 1 Chris Petersen 2004-11-10 18:45:47 EST
found the fix listed in 

http://download.fedora.redhat.com/pub/fedora/linux/core/3/i386/os/RELEASE-NOTES-en.html
Comment 2 Ulrich Seidl 2004-11-17 02:54:57 EST
Ok. I think the fix will be to change to SUSE Linux. They seem to be
more userfriendly. Additionally, the installation of WLAN and ISDN is
more easy with SUSE Linux.
Comment 3 Joe Henley 2004-11-17 17:46:55 EST
Sorry, but the explanation in the Release Notes is wrong -- doesn't
work as described.  Please re-look at it to make it clear.  What is
the "architecture,' and how about an example.  The file do not get put
in /usr/src/redhat.  Etc., etc.

Please clean it up.
Comment 4 Ted 2004-11-29 04:28:05 EST
I was really starting to like Fedora Core 3 until I ran into this
kernel-source train wreck.  Great job guys, you went and made
something so simple that I didn't have to ever look at it into
something complicated enough to be annoying; simply because it was
"redundant".

Not that you care, but I hate this new policy of annoying the users.

Note You need to log in before you can comment on or make changes to this bug.