Bug 138775 - NFS mount command should retry "fg" mount requests
NFS mount command should retry "fg" mount requests
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: util-linux (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
: 168810 (view as bug list)
Depends On:
Blocks: 156320
  Show dependency treegraph
 
Reported: 2004-11-10 21:32 EST by Chuck Lever
Modified: 2007-11-30 17:07 EST (History)
7 users (show)

See Also:
Fixed In Version: RHBA-2005-626
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 11:50:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
minimal patch to make the mount command retry NFS mount requests (2.36 KB, patch)
2004-11-10 21:34 EST, Chuck Lever
no flags Details | Diff

  None (edit)
Description Chuck Lever 2004-11-10 21:32:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
NFS mounts can be performed in the foreground, or in the background.
Foreground mounts are tried once, and will fail immediately if there
is any problem.  Background mounts allow the mount command to fork
a process if the first mount attempt fails that will run in the
background until the mount request succeeds.

Sometimes it is desirable for foreground mounts to retry, as well.
For example, a busy NFS server may drop a mount request, in which
case the mount command on the client should retry a couple of
times before giving up completely.

Version-Release number of selected component (if applicable):
mount-2.11g-6

How reproducible:
Sometimes

Steps to Reproduce:
1. Try an NFS mount request with the "fg" option against a very busy 
NFS server
2.
3.
    

Actual Results:  If the server drops the request, the mount command 
will exit with an error.

Expected Results:  If the server drops the request, the mount command 
should retry the requests a couple of times before giving up.

Additional info:

Oracle has hit this problem, and would like it addressed in RHEL AS 
2.1 and in RHEL 3.0.
Comment 1 Chuck Lever 2004-11-10 21:34:33 EST
Created attachment 106469 [details]
minimal patch to make the mount command retry NFS mount requests

here's a patch i created a couple of months ago for Oracle.
Comment 2 Chuck Lever 2004-11-10 21:38:57 EST
Note that these issue tracker numbers are relevant:

RHIT: 46917 (RHEL AS 2.1), 46918 (RHEL 3.0)
Comment 3 Damian Menscher 2005-03-21 23:57:03 EST
I'm seeing this under RH9.

Probably worth noting that the nfs(5) manpage explicitly states that a NFS 
mount in the foreground "fg" will retry.

Anyone know if the bg option works as advertised?  I might have to switch to 
that, just to get filesystems mounted.
Comment 4 Suzanne Hillman 2005-03-30 13:13:34 EST
The RHEL2.1 IT you pointed to expressly said: 

"At this time, we are not planning on adding new features to RHEL2.1. Red Hat
Enterprise Linux 2.1 has entered its Deployment Support phase. 
During the Deployment Support phase, only qualified security and bug fix
errata will be applied to the Enterprise products via updates. For more
information on the Red Hat Enterprise Linux Errata Support Policy, see:

" http://www.redhat.com/security/updates/errata/

"Based on the information available in this ticket, this feature request
does not meet the criteria to qualify for an errata in the Deployment
Support phase.  Thus, this feature request is being closed for the RHEL
2.1 update series."


Because of this, I am moving this bug to RHEL3, and cloning a copy for RHEL4.
Comment 5 Suzanne Hillman 2005-03-30 13:19:54 EST
Cloned bug for RHEL4 as bug 152599.
Comment 8 Steve Dickson 2005-06-08 16:17:40 EDT
This should be fixed in util-linux-2.11y-31.7 
Comment 14 Red Hat Bugzilla 2005-09-28 11:50:09 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-626.html
Comment 15 Steve Dickson 2005-10-20 15:46:11 EDT
*** Bug 168810 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.