Bug 1387782 - WebUI: Services are not displayed correctly after upgrade
Summary: WebUI: Services are not displayed correctly after upgrade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Nikhil Dehadrai
URL:
Whiteboard:
: 1399247 (view as bug list)
Depends On:
Blocks: 1390662
TreeView+ depends on / blocked
 
Reported: 2016-10-21 21:17 UTC by Petr Vobornik
Modified: 2017-08-01 09:42 UTC (History)
7 users (show)

Fixed In Version: ipa-4.4.0-14.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1390662 (view as bug list)
Environment:
Last Closed: 2017-08-01 09:42:02 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of WebUI Identity > Services (55.26 KB, image/png)
2017-05-31 11:36 UTC, Nikhil Dehadrai
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2304 normal SHIPPED_LIVE ipa bug fix and enhancement update 2017-08-01 12:41:35 UTC

Description Petr Vobornik 2016-10-21 21:17:19 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/6397

Description:
After upgrading from FreeIPA 4.3.2 to FreeIPA 4.4 the WebUI does not show services which don't have canonical name. 

Steps to reproduce:
1. Install FreeIPA 4.3.2
2. Upgrade to FreeIPA 4.4
3. Go to the WebUI, Identity -> Services
4. There are only two lines and the second one is empty

Comment 5 Pavel Vomacka 2016-11-29 12:42:05 UTC
*** Bug 1399247 has been marked as a duplicate of this bug. ***

Comment 7 Nikhil Dehadrai 2017-05-31 11:34:41 UTC
ipa-server version: ipa-server-4.5.0-13.el7.x86_64

1. Verified that upon upgrade of IPA server to latest version at WebUI, Identity -> Services, the details are displayed correctly.
2. Verified the same from following upgrade path:
- RHEL 7.1.z > RHEL 7.4
- RHEL 7.2.z > RHEL 7.4
- RHEL 7.3.z > RHEL 7.4
3. The same behavior is observed on a freshly installed IPA-server at latest version. (Refer attached screenshot)

Thus on the basis of above observation, marking status of bug to "VERIFIED"

Comment 8 Nikhil Dehadrai 2017-05-31 11:36:42 UTC
Created attachment 1283699 [details]
Screenshot of WebUI Identity > Services

Screenshot of WebUI Identity > Services

Comment 9 errata-xmlrpc 2017-08-01 09:42:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2304


Note You need to log in before you can comment on or make changes to this bug.