Bug 138779 - X freezes when starting couple of applications
X freezes when starting couple of applications
Status: CLOSED DUPLICATE of bug 138108
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
ftp://thales.csi.hu/mw/fc3_freeze
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-10 22:39 EST by Mate Wierdl
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mate Wierdl 2004-11-10 22:39:06 EST
Description of problem: 
 
X freezes the box after starting 2nd xterm from menu 
Version-Release number of selected component (if applicable): 
 
xorg-x11-6.8.1-12 
 
How reproducible: 
 
always 
 
Steps to Reproduce: 
1. boot 
2. login  
3. start xterm from gnome menu, and start another one 
 
   
Actual results: 
 
The box freezes, and cannot be accessed even via ssh; has to be 
powered off manually. 
 
Expected results: 
 
Well, no freeze. 
 
Additional info: 
 
The application I start does not have to be an xterm; I just gave 
that because it produces consistent "results". 
 
The only message I see in log/messages is a repetition of 
 
Nov 10 10:09:51 thales kernel: atkbd.c: Spurious ACK on 
isa0060/serio0. Some program, like XFree86, might be trying access 
hardware directly. 
 
Other system info: 
 
$ uname -a 
Linux thales.memphis.edu 2.6.9-1.667smp #1 SMP Tue Nov 2 14:59:52 EST 
2004 i686 athlon i386 GNU/Linux 
 
The video chip is an ATI Radeon 7000. 
 
I have put some stuff to 
 
ftp://thales.csi.hu/mw/fc3_freeze 
 
presently, you can find the log/messages file, the xorg logfiles, and 
the yum log file there since I did my FC2-FC3 upgrade via yum. 
I updated my system 11/09/2004 
 
I will put a strace output of startx on the ftp site if you suggest a 
good way of running the command.  When I ran it with the -f flag, it 
created a 250M file in couple of minutes while I produced the freeze.
Comment 1 Mate Wierdl 2004-11-12 18:08:38 EST
In the meantime, I reverted all my xorg updates, and updated the system
with anaconda.  No dice, X still crashes the system, so the problem is 
very probably not caused by yum's update.

Presently I am happily running the old xorg from FC2.

At the above ftp site there are a couple of strace outputs.

My name is Mate Wierdl
Comment 2 Hugo Van den Berg 2004-11-14 16:31:37 EST
This bug is the same as 138539
Comment 3 Mate Wierdl 2004-11-22 11:30:01 EST
As suggested in bug#138539,  commenting out  
 
load "dri" 
 
in xorg.conf eliminates the problem. 
Comment 4 Kristian Høgsberg 2004-11-23 17:36:02 EST
This is most likely a dupe of bug #138108, for which I believe we now
have a fix.  xorg-x11-6.8.1-17 or later in rawhide should make the
crashes go away, and we'll be putting out an update shortly for FC3. 
Please test either the udpate or the rawhide packages so we can
confirm that this is indeed the same issue.  Thanks.

*** This bug has been marked as a duplicate of 138108 ***
Comment 5 Mate Wierdl 2004-11-23 22:57:12 EST
bugzilla would not let me access bug #138108 even after I logged in. 
Comment 6 Red Hat Bugzilla 2006-02-21 14:06:54 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.