Bug 138783 - bitmap wide Latin chars in Japanese and Korean pango text
bitmap wide Latin chars in Japanese and Korean pango text
Status: CLOSED DUPLICATE of bug 107952
Product: Fedora
Classification: Fedora
Component: pango (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-11 00:14 EST by Jens Petersen
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
firefox-ja-no-pango-yahoo.png (137.70 KB, image/png)
2004-11-11 00:16 EST, Jens Petersen
no flags Details
firefox-ja-pango-yahoo.png (139.02 KB, image/png)
2004-11-11 00:23 EST, Jens Petersen
no flags Details

  None (edit)
Description Jens Petersen 2004-11-11 00:14:20 EST
Description of problem:
Running firefox with pango enabled, I see ASCII text in
Japanese rendered badly at the wrong size and with a bitmap
font that makes it stand out.  This is on a FC3 box.

Version-Release number of selected component (if applicable):
firefox-1.0-1

How reproducible:
every time

Steps to Reproduce:
1. Start a new firefox session with:
$ LANG=ja_JP.UTF-8 firefox
"http://headlines.yahoo.co.jp/hl?a=20041111-00000202-yom-bus_all"
2. Start a new firefox session with:
$ MOZ_ENABLE_PANGO=1 LANG=ja_JP.UTF-8 firefox
"http://headlines.yahoo.co.jp/hl?a=20041111-00000202-yom-bus_all"
  
Actual results:
(1) renders well with ASCII in the same font as the Japanese text as expected.
(2) renders with ASCII in an undersized bitmap font which looks bad.

Expected results:
(2) Should look pretty much like (1) with the same anti-aliased font for
ASCII text.
Comment 1 Jens Petersen 2004-11-11 00:16:32 EST
Created attachment 106472 [details]
firefox-ja-no-pango-yahoo.png

Shot of (1) without pango.  Notice how "FRB" etc is in the right
size and font.
Comment 2 Jens Petersen 2004-11-11 00:23:08 EST
Created attachment 106473 [details]
firefox-ja-pango-yahoo.png

With pango (2).  Notice how "FRB" in the title is tiny and
the other ascii text in the text too.

Actually the highlighted bracketed text moves around when it
is highlighted - though it can't be seen in this this screenshot.
The openning "(" is actually rendered correctly, but the "FRB)"
is small: when highlighted this text moves around.
Comment 3 Nakai 2004-11-11 00:53:51 EST
Try install Japanese translation for firefox.

There is a similar bug for Mozilla:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=107617
Comment 4 Jens Petersen 2004-11-11 01:19:05 EST
Pango seems to fix the problem in bug 107617. :)
The problem reported here is a problem caused by pango rendering.
Comment 5 Warren Togami 2004-11-12 02:07:29 EST
Reassigning to pango.  You can see this behavior in other pango using
applications.  One example:

1. xchat
2. enable cannaLE
3. Type "The"
4. Hit SPACE ENTER
5. Type "TESThe"
6. hit SPACE ENTER

Result:
Tへ has the "T" is smaller than へ because it is an ugly bitmap font.
TESTへ has "TEST" the same size as へ.
Comment 6 Warren Togami 2004-11-12 02:17:48 EST
Oops, the test case in Comment #5 above is bad.

However this is still a pango or font problem where multibyte latin
characters are falling back to the bitmap fonts.
Comment 7 Leon Ho 2004-11-12 02:23:13 EST
Those two test cases are just the way CannaLE outputs.

The real question is: the multibyte 'T' (ï¼´) is using Fixed seems, and
Kochi has that glyphs (U+FF34)
Comment 8 Leon Ho 2004-11-12 02:26:10 EST
Owen, seems pango is using Fixed for the multibyte 'T' (ï¼´). Is it a
known behavior on pango? (as mentioned, Kochi has that glyphs (U+FF34))
Comment 10 Owen Taylor 2004-11-18 13:13:53 EST
This is basicallya dup of bug 107952. Pango says 'T', that's
Latin, not Han, this 'ja' language tag doens't make sense,
let me tag this with 'en'. But fontconfig doesn't consider
that Kochi is a good font for the 'en' language tag.

Probably easiest fix is to strip down the 'en' coverage that
fontconfig requires to not have all extended characters.

A fix for this specifically would be to reassign wide latin
characters to be Han instead of Latin, or to make them script
neutral. But that would cause Pango's script assigmments to
deviate from the Unicode standard, which I don't like.


*** This bug has been marked as a duplicate of 107952 ***
Comment 11 Jens Petersen 2005-03-01 06:03:04 EST
I just tried fontconfig-2.2.99 and it seems to fix this issue too. :)

Will it be in fc4?
Comment 12 Red Hat Bugzilla 2006-02-21 14:06:55 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.