Bug 138784 - On upgrade, gets confused when root is on LVM.
On upgrade, gets confused when root is on LVM.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-11 00:15 EST by Aleksey Nogin
Modified: 2007-11-30 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-11 02:56:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2004-11-11 00:15:50 EST
I was upgrading Fedora Core 1 (with all updates) to Fedora Core 3. My
root partition was on LVM. The grub.conf was not updated correctly,
leaving machine unbootable.

Relevant part of upgrade.log:

...
Upgrading mkinitrd-4.1.18-2.i386.
Upgrading kernel-2.6.9-1.667.i686.
unable to stat /dev/Main/Root: 2
grubby fatal error: unable to find a suitable template
grubby fatal error: unable to find a suitable template
grubby: doing this would leave no kernel entries. Not writing out new
config.
Upgrading kernel-smp-2.6.9-1.667.i686.
unable to stat /dev/Main/Root: 2
grubby fatal error: unable to find a suitable template
...

The /etc/grub.conf after upgrade contained:
-----
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this
file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/Main/Root
#          initrd /initrd-version.img
#boot=/dev/hda
default=0
timeout=10
splashimage=(hd0,0)/grub/splash.xpm.gz
title Fedora Core (2.4.22-1.2199.nptlsmp)
	root (hd0,0)
	kernel /vmlinuz-2.4.22-1.2199.nptlsmp ro root=/dev/Main/Root rhgb
	initrd /initrd-2.4.22-1.2199.nptlsmp.img
-------------

In order to get the machine to boot again, I had to (manually):
- recreate the initrds for 2.6.9-1.667 and 2.6.9-1.667smp (the ones
created automatically during the FC1->FC3 upgrade did not have the LVM
stuff).
- replace the 2.4.22-1.2199.nptlsmp entry in grub.conf with
appropriate 2.6.9-1.667smp and 2.6.9-1.667 entries
Comment 1 Jeremy Katz 2004-11-11 13:49:20 EST
FC1 -> FC3?  Urgh :/

I fixed this for FC2 -> FC3, but I can definitely see how FC1 -> FC3
could be different with the lvm1->lvm2 transition.
Comment 8 Jeremy Katz 2004-11-22 17:08:02 EST
Fixed with new udev package.
Comment 9 Jay Turner 2005-02-10 08:30:52 EST
Any feedback on if this latest udev package resolved the issue?
Comment 10 Aleksey Nogin 2005-02-10 15:36:17 EST
Since the machine that caused this problem is already upgraded, I do not really
have a way to test this.
Comment 11 Jay Turner 2005-02-11 02:56:20 EST
I'm not seeing other reports with the new udev, so going to close this out. 
Will reopen if things rear their ugly heads again.

Note You need to log in before you can comment on or make changes to this bug.