Bug 1387862 - [abrt] hexchat: pevent_make_pntevts(): hexchat killed by SIGABRT
Summary: [abrt] hexchat: pevent_make_pntevts(): hexchat killed by SIGABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hexchat
Version: 24
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Patrick Griffis
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:a44557a7312a3d7dc020bb21a83...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-22 17:20 UTC by Francisco de la Peña
Modified: 2016-10-26 22:30 UTC (History)
3 users (show)

Fixed In Version: hexchat-2.12.3-1.fc24 hexchat-2.12.3-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-25 20:21:18 UTC
Type: ---


Attachments (Terms of Use)
File: cgroup (242 bytes, text/plain)
2016-10-22 17:20 UTC, Francisco de la Peña
no flags Details
File: core_backtrace (1.30 KB, text/plain)
2016-10-22 17:20 UTC, Francisco de la Peña
no flags Details
File: dso_list (10.71 KB, text/plain)
2016-10-22 17:20 UTC, Francisco de la Peña
no flags Details
File: limits (1.29 KB, text/plain)
2016-10-22 17:20 UTC, Francisco de la Peña
no flags Details
File: mountinfo (3.50 KB, text/plain)
2016-10-22 17:20 UTC, Francisco de la Peña
no flags Details
File: namespaces (102 bytes, text/plain)
2016-10-22 17:20 UTC, Francisco de la Peña
no flags Details
File: proc_pid_status (1.10 KB, text/plain)
2016-10-22 17:20 UTC, Francisco de la Peña
no flags Details
File: var_log_messages (414 bytes, text/plain)
2016-10-22 17:20 UTC, Francisco de la Peña
no flags Details

Description Francisco de la Peña 2016-10-22 17:20:11 UTC
Description of problem:
This crash is always reproducible on Spanish locales due to a missing string translation. Updating hexchat to 2.12.3 should fix this issue.

Version-Release number of selected component:
hexchat-2.12.2-1.fc24

Additional info:
reporter:       libreport-2.7.2
backtrace:      
backtrace_rating: 4
cmdline:        hexchat --existing
crash_function: pevent_make_pntevts
environ:        LANG=es_CR.UTF-8
executable:     /usr/bin/hexchat
global_pid:     2072
kernel:         4.7.7-200.fc24.x86_64
maps:           
open_fds:       
pkg_fingerprint: 73BD E983 81B4 6521
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:

Comment 1 Francisco de la Peña 2016-10-22 17:20:18 UTC
Created attachment 1213136 [details]
File: cgroup

Comment 2 Francisco de la Peña 2016-10-22 17:20:20 UTC
Created attachment 1213137 [details]
File: core_backtrace

Comment 3 Francisco de la Peña 2016-10-22 17:20:21 UTC
Created attachment 1213138 [details]
File: dso_list

Comment 4 Francisco de la Peña 2016-10-22 17:20:23 UTC
Created attachment 1213139 [details]
File: limits

Comment 5 Francisco de la Peña 2016-10-22 17:20:24 UTC
Created attachment 1213140 [details]
File: mountinfo

Comment 6 Francisco de la Peña 2016-10-22 17:20:26 UTC
Created attachment 1213141 [details]
File: namespaces

Comment 7 Francisco de la Peña 2016-10-22 17:20:27 UTC
Created attachment 1213142 [details]
File: proc_pid_status

Comment 8 Francisco de la Peña 2016-10-22 17:20:29 UTC
Created attachment 1213143 [details]
File: var_log_messages

Comment 9 Fedora Update System 2016-10-24 03:51:38 UTC
hexchat-2.12.3-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-2ec5259ddc

Comment 10 Fedora Update System 2016-10-24 04:52:47 UTC
hexchat-2.12.3-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3ab0660a3e

Comment 11 Fedora Update System 2016-10-25 20:21:18 UTC
hexchat-2.12.3-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2016-10-26 22:30:22 UTC
hexchat-2.12.3-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.