Bug 138795 - disklessrc fails to setup different network cards on diskless client
Summary: disklessrc fails to setup different network cards on diskless client
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-netboot   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Fabio Olive Leite
QA Contact:
URL:
Whiteboard:
Keywords: Patch
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-11 07:38 UTC by Mustafa Mahudhawala
Modified: 2012-04-27 19:02 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-27 19:02:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to enable disklessrc detect multiplt network cards (793 bytes, patch)
2004-11-11 07:54 UTC, Mustafa Mahudhawala
no flags Details | Diff

Description Mustafa Mahudhawala 2004-11-11 07:38:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20040924

Description of problem:
disklessrc fails to setup multiple ethernet cards on the diskless
client, if they are of different type i.e. require different modules.
In this case it just initialises the first card (eth0)

The problem seems to be in the implementation of findhardware() function.

Due to this, the ETHERNET= option which allows selecting the interface
to use for networking, is crippled as other interfaces (eth1 and
above) are no longer avaliable.



Version-Release number of selected component (if applicable):
redhat-config-netboot-0.1.1-19

How reproducible:
Always

Steps to Reproduce:
evident from the program logic.

Actual Results:  Loads the module corresponding to the first ethernet
card only.

Expected Results:  Should load all the required modules depending on
the installed/available ethernet cards.

Additional info:

Comment 1 Mustafa Mahudhawala 2004-11-11 07:54:19 UTC
Created attachment 106480 [details]
Patch to enable disklessrc detect multiplt network cards

Comment 2 Daniel Walsh 2004-11-11 13:05:22 UTC
Added patch in system-config-netboot-0.1.10-1

Comment 4 Fabio Olive Leite 2012-04-27 19:02:03 UTC
This bug has not had any activity for years. Closing as NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.