Bug 138800 - Hard reboot causes system to hang on "kernel perimeters"
Hard reboot causes system to hang on "kernel perimeters"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-11 04:10 EST by Colin Ritter
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-18 10:57:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Ritter 2004-11-11 04:10:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
After suffering a lock-up in OpenOffice I performed a hard shutdown. 
When I rebooted it stopped on "Kernel Perimeters" and would not
continute.  When I pressed "Ctrl-c" it continued to runlevel 5, but
without read-write access to the disks.  I could not log in to any
account.  The only way I knew to fix this was to reinstall Fedora Core 3.


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:

I had installed nVidia drivers via RPM since kernel source is
unavailable to install using nVidia's installer.

My system was fully up to date at the time.

Besides that I had installed several media players and internet utilities.

I had the same problem under FC3 test 3.
Comment 1 Daniel Hedblom 2004-11-12 19:49:52 EST
The problem is very reproducable. Do an xorg.conf file that is broken
and it will happen. I had it happen on two separate computers today.
The system blinks when it tries to load X and then just hangs when
sending kernel parameters. Fix xorg.conf and the system boots again as
normal.
Comment 2 Alar Suija 2004-11-13 13:33:01 EST
During bootup, delete parameter "rhgb" using grub editor. After boot
you can use X setup utility (or utility starts automatically).
Comment 3 Mike A. Harris 2004-11-18 10:57:14 EST
Thanks for the report.  For users who are experiencing problems
installing, configuring, or using the unsupported 3rd party
proprietary "nvidia" video driver, Nvidia provides indirect
customer support via an online web based support forum.  Nvidia
monitors these web forums for commonly reported problems and
passes them on to Nvidia engineers for investigation.  Once
they've isolated a particular problem, it is often fixed in
a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums,
others who may have experienced the particular problem may
be able to assist.  If there is a real bug occuring, Nvidia
will be able to determine this, and will likely resolve the
issue in a future driver update for the operating system
releases that they officially support.

While Red Hat does not support the proprietary nvidia driver,
users requiring technical support may also find the various
X.Org, XFree86, and Red Hat mailing lists helpful in finding
assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo

Setting status to "NOTABUG" (unsupported).
Comment 4 J.D. Luke 2004-12-16 11:39:06 EST
While I realize that this is technically an nVidia problem, it strikes
a relatively large number of users.

I personally would like to see:

1) A fall-back position that recognizes a failure to initialize the
rhgb, and continues in text-mode.

2) An additional entry in the GRuB menu for a 'fail-safe' text-mode boot.

This would make things considerably easier for many, I know I
certainly banged my head against this one for a while after my FC3
upgrade.

Interestingly, this happened on only one of the two machines I
upgraded, because I just happen to have been running a plain vanilla
2.6.9 kernel on one box, and had configured the nVidia drivers for
that kernel...  It was apparently compatible enough with the kernel on
the FC3 DVD to allow function.

Note You need to log in before you can comment on or make changes to this bug.