Bug 138811 - Xorg breaks apm suspend to RAM
Xorg breaks apm suspend to RAM
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-11 06:19 EST by David Lowe
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-22 11:05:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Possible fix for Radeon Screen corruption on APM Resume (791 bytes, patch)
2004-12-22 10:10 EST, Benjamin Long
no flags Details | Diff

  None (edit)
Description David Lowe 2004-11-11 06:19:33 EST
Description of problem:
Apm suspend to RAM worked fine in xorg in FC2 but now seems to be
broken in FC3. Any attempt to resume from suspend now results in a
hard lockup of the computer if xorg is running at the time of suspend.
Switching to virtual consoles prior to suspend does not help.

However the problem is much more serious than that. Suspend to RAM
works fine if I boot to runlevel 3 (no xorg). If I then start and stop
the x server (and double check to make sure all processes and kernel
modules are back to what was running prior to starting x),
I am back to the hard lockup problem on resume.

Version-Release number of selected component (if applicable):
Am using xorg-x11-6.8.1-12
         kernel 2.6.9-1.667 with the radeon driver on a
Dell Inspiron 4150 laptop, which uses a radeon mobility 7500 graphics
card.


How reproducible:
Every time

Steps to Reproduce:
1. Boot to runlevel 3, and log in
2. Apm suspend to RAM works fine
3. startx
4. crtl-alt-backspace
  
Actual results:
Resume from Apm suspend gives a hard lockup

Expected results:
Should work fine as it did in FC2

Additional info:
Comment 1 David Lowe 2004-11-11 19:38:27 EST
I dropped back to version 6.7 which fixed the problem.
Unfortunately I won't be able to help with further testing.
Comment 2 David Lowe 2004-11-16 18:22:54 EST
One further note: I tried going back up to xorg-x11-6.8 and only copying 
radeon_drv.o and ati_drv.o from version 6.7 back. This also fixed the
problem with suspend, so now it should be easier for me to test any
proposed solutions :)
Comment 3 David Lowe 2004-12-02 18:55:19 EST
Seems to be fixed as of the most recent xorg-x11 update
6.8.1-12.FC3.21

Thanks 
Comment 4 Benjamin Long 2004-12-22 10:08:13 EST
I'm having a very similar problem with my Dell 600m. When I resume,
the display is completely corupted. The screen starts out black and
then white spreads out on it, like milk spilled on it. Within about 10
sec the entire screen is white. It's very strange. I asked what it was
on the Linux on Dell Laptops Yahoo mailing list and got the response
that it was a known problem and a patch was dropped from FC2 to FC3
for some reason. I've attached the patch he gave me. Is this already
applied? Do I have a completely diffrent problem?
Comment 5 Benjamin Long 2004-12-22 10:10:14 EST
Created attachment 109021 [details]
Possible fix for Radeon Screen corruption on APM Resume

Is this patch already applied in the latest xorg update
(xorg-x11-6.8.1-12.FC3.21)?
Comment 6 Mike A. Harris 2004-12-22 11:05:07 EST
In reply to comment #3:

Thanks for the feedback David.  We also will be releasing 6.8.2
for FC3 soon, which has additional fixes for radeon.


In reply to comment #4 & 5:

Please test the latest erratum for FC3, and if the problem persists,
upgrade to the xorg-x11-6.8.1.901 or newer release from rawhide,
as that is ultimately what will be the next update release for
FC3 as well.  After testing this, should the problem persist for
you, then it is not the same problem described by the original
reporter in this report.  In that case, file a new bug report
in freedesktop.org bugzilla at http://bugs.freedesktop.org in
the "xorg" component and attach your X server log and config
file as individual file attachments in Xorg bugzilla.  This will
allow X.Org developers to be aware of the problem if it persists,
and potentially to fix it sooner.

Setting status to "ERRATA"

Note You need to log in before you can comment on or make changes to this bug.