Bug 138813 - up2date does not function
up2date does not function
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-11 06:33 EST by Benjamin Franklin Rossen
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 18:39:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Benjamin Franklin Rossen 2004-11-11 06:33:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
up2date does not work, with several patterns of failure. 
First time, I had installed everything from f2. After updating a week
later, the entire system failed to reboot. It was necessary to
reformat my disk and re-install Fedora 2. The second time I
selectively installed only the components I needed (I am a web
developer and use PHP and MySQL; and use the usual OpenOffice for
general administration of my business). This time up2date hung after
being on line for hours. It is unable to find libxml2-2.6.16-2. I have
tried this several times, at different times of the day and night with
the same result. 
This seems to be a server end problem... hence not caused by up2date
itself; however, I cannot tell. 


Version-Release number of selected component (if applicable):
up2date-4.3.19-1

How reproducible:
Always

Steps to Reproduce:
1. Launch up2date
2. Select all packets to be updated 
3. come back again hours later to see that nothing is happening 
    

Actual Results:  system hangs.

Expected Results:  system updates.

Additional info:

I shall leave the severity setting on normal, although I think this
should be regarded as a potentially critical failurs. It is a catch
all for all other system and application failures. When any other
component of the system fails or is not operating optimally, the
obvious remedy is to apply up to date packages. When this fails the
user is confronted with a double frustration (1) the initial failure
and (2) the inability to do anything about it even when repaired up to
date packages might exist. For myself, the RPM was a major factor in
selecting Red Hat over other releases. You may wisely elect to
consider all up2date bug reports as having a higher priority by default.
Comment 1 Benjamin Franklin Rossen 2004-11-13 04:20:49 EST
Further comments: 
I was finally able to update my system by leaving it running for
nearly 24 hours; reminding me of the days of audio-modens. I have a
100 MIPS glass fibre coming directly into this workstation from the
backbone of the internet (not into my network... into this work
station). It should be possible to download the entire operating
system in a few minutes. The slowness of the connection when driven by
up2date must be a result to some other bottle neck. It seems likely
that your servers are not able to provide the bandwidth required to
make the up2date services operate as they should. In any case, the
problem seems not to be caused by the up2date itself. 
Benjamin Rossen 
Comment 2 Matthew Miller 2005-04-26 12:13:03 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 3 Todd Warner 2005-09-23 18:39:55 EDT
this is a non-issue it seems. Closing. Reopen/refile if you feel differently.

Note You need to log in before you can comment on or make changes to this bug.