Bug 138814 - diskdump on megaraid stalls after printing "start dumping"
diskdump on megaraid stalls after printing "start dumping"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Tatsuo Uchida
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-11 07:04 EST by Jun'ichi NOMURA
Modified: 2007-11-30 17:07 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 15:56:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jun'ichi NOMURA 2004-11-11 07:04:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.7.2)
Gecko/20040820 Debian/1.7.2-4

Description of problem:
While using megaraid2.o driver,
diskdump stalls before writing dump to dump device.


Version-Release number of selected component (if applicable):
2.4.21-23.EL

How reproducible:
Almost Always

Steps to Reproduce:
1. Set up diskdump with dump device on megaraid2.o
2. Crash kernel by SysRq+c
3.
    

Actual Results:
 dump procedure stops at displaying message:
 ...
 CPU frozen: #0#1#2#3
 CPU#0 is executing diskdump.
 start dumping
 <here>



Expected Results:
 CPU frozen: #0#1#2#3
 CPU#0 is executing diskdump.
 start dumping
 check dump partition
 ...


Additional info:

This problem does not occur with aic79xx.
Comment 3 Ernie Petrides 2004-11-11 19:34:30 EST
*** Bug 138815 has been marked as a duplicate of this bug. ***
Comment 4 Jun'ichi NOMURA 2004-11-12 08:07:28 EST
The latest beta (2.4.21-24.EL) includes a fix to this problem.
It successfully finish writing dump.
Comment 6 Tatsuo Uchida 2004-11-12 15:25:49 EST
It is fixed by 2.4.21-24.EL (diskdump-megaraid2a.patch).
Comment 8 John Flanagan 2004-12-20 15:56:57 EST
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-550.html

Note You need to log in before you can comment on or make changes to this bug.