Bug 138824 - system-config-lvm fails around editing fstab
Summary: system-config-lvm fails around editing fstab
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2   
(Show other bugs)
Version: 4.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Jim Parsons
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-11 13:43 UTC by John Haxby
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-11 14:35:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of LVM creation dialog box (29.59 KB, image/png)
2004-11-11 13:50 UTC, John Haxby
no flags Details

Description John Haxby 2004-11-11 13:43:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
system-config-lvm fails to create a logical volume and produces a
python error:

/usr/lib/python2.3/site-packages/gtk-2.0/gtk/__init__.py:90:
GtkDeprecationWarning: gtk.mainloop is deprecated, use gtk.main instead
  self.warn(message, DeprecationWarning)
Traceback (most recent call last):
  File "/usr/share/system-config-lvm/InputController.py", line 654, in
on_ok_new_lv_button
    new_lv_command_set[NEW_FSTAB_ARG] = FSTAB_entry
NameError: global name 'NEW_FSTAB_ARG' is not defined

There's also a relatively minor layout issue -- see the screenshot I'm
going to attach in a minute.

Version-Release number of selected component (if applicable):
system-config-lvm-0.9.3-1.0

How reproducible:
Always

Steps to Reproduce:
1. (See attached screenshot)
2. Click on the OK button.
3.
    

Actual Results:  No logical volume created.

Expected Results:  A logical volume to be created and an entry written
to /etc/fstab

Additional info:

I did think that perhaps it was attempting to create a very small
logical volume (8Mb, I actually meant 8Gb) but when I repeated the
exercise with a properly sized logical volume it still failed.  It
wasn't until I unchecked the "Check here if you wold like an entry to
be made in /etc/fstab" box that I could create the logical volume.

Since the most tedious part (for me) of creating a new logical volume
is editing /etc/fstab this does rather tend to render the tool less
than useful :-)

Comment 1 John Haxby 2004-11-11 13:50:04 UTC
Created attachment 106496 [details]
Screenshot of LVM creation dialog box

Comment 2 Jim Parsons 2004-11-11 14:35:21 UTC
The automatic creation of an fstab entry feature is being pulled for
the initial release and has been put in feature tracker for U1.

Comment 3 John Haxby 2004-11-11 15:16:43 UTC
That's a shame -- it's the one feature I liked (being a bit of a
veteran of the lvm command line).

Comment 4 Jim Parsons 2004-11-11 15:27:31 UTC
Just to let you know, it will not be lost, and if it can be squeezed
in it might make it in the initial release yet. There is just a
dwindling amount of time to insure it is adequately tested -- I think
any part of an application that writes to an important /etc file that
is read on startup had better work with no flaws. 


Note You need to log in before you can comment on or make changes to this bug.