Bug 138825 - via_drv.o mising in x86_64
via_drv.o mising in x86_64
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-11 08:46 EST by Thorsten Leemhuis
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-01 00:02:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log from 64 bit X-session (16.28 KB, text/plain)
2004-11-22 03:16 EST, Thorsten Leemhuis
no flags Details
Log from 32 bit X-Session (16.33 KB, text/plain)
2004-11-22 03:16 EST, Thorsten Leemhuis
no flags Details
32 bit xorg.conf (2.78 KB, text/plain)
2004-11-22 03:17 EST, Thorsten Leemhuis
no flags Details
32 bit log with via driver from viaarena.com (38.93 KB, text/plain)
2004-11-22 03:17 EST, Thorsten Leemhuis
no flags Details
64 bit xorg.conf (2.64 KB, text/plain)
2004-11-22 03:19 EST, Thorsten Leemhuis
no flags Details
lspci, lspci -n , lspci -v (6.60 KB, text/plain)
2004-11-22 03:19 EST, Thorsten Leemhuis
no flags Details

  None (edit)
Description Thorsten Leemhuis 2004-11-11 08:46:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; rv:1.7.3)
Gecko/20041020 Firefox/0.10.1

Description of problem:
[thl@thl 3]$ rpm -qpl x86_64/Fedora/RPMS/xorg-x11-6.8.1-12.x86_64.rpm
| grep via
[thl@thl 3]$ rpm -qpl i386/Fedora/RPMS/xorg-x11-6.8.1-12.i386.rpm |
grep via
/usr/X11R6/lib/modules/drivers/via_drv.o
/usr/X11R6/man/man4/via.4x.gz
[thl@thl 3]$


Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12.x86_64.rpm
Comment 1 Mike A. Harris 2004-11-12 14:00:43 EST
The via driver has never been built or shipped before on AMD64
systems, because there wasn't any AMD64 systems with via video
before.

Do you have an AMD64 or EM64T motherboard with onboard via video?
If so, please attach your X server log and config file for us
to review.

Thanks in advance.
Comment 2 Thorsten Leemhuis 2004-11-13 03:20:01 EST
>The via driver has never been built or shipped before on AMD64
>systems, because there wasn't any AMD64 systems with via video
>before.

There is a VIA Chipset for AMD64 here:
http://www.via.com.tw/en/products/chipsets/k8-series/k8m800/

An products based on it (those I know ;-) ):
http://www.shuttle.com/hq/product/barebone/specification.asp?B_id=34
http://www.dfi.com.tw/Product/xx_product_spec_details_r_us.jsp?PRODUCT_ID=3060&CATEGORY_TYPE=INFINITY&SITE=US
http://www.msi.com.tw/program/products/mainboard/mbd/pro_mbd_detail.php?UID=621

>Do you have an AMD64 or EM64T motherboard with onboard via video?
>If so, please attach your X server log and config file for us
>to review.

I had a test system -- I'll build it together again on monday and will
provide some data here. But after reporting this bug I found out that
even the 32-bit FC3 driver doesn't work on it (as in Suse 9.2 32bit
and 64bit also). 

Wondering why, cause
http://freedesktop.org/~xorg/X11R6.8.1/doc/via.4.html
claims the K8M800 is supported.
Comment 3 Thorsten Leemhuis 2004-11-22 03:16:03 EST
Created attachment 107163 [details]
Log from 64 bit X-session
Comment 4 Thorsten Leemhuis 2004-11-22 03:16:41 EST
Created attachment 107164 [details]
Log from 32 bit X-Session
Comment 5 Thorsten Leemhuis 2004-11-22 03:17:01 EST
Created attachment 107165 [details]
32 bit xorg.conf
Comment 6 Thorsten Leemhuis 2004-11-22 03:17:38 EST
Created attachment 107166 [details]
32 bit log with via driver from viaarena.com
Comment 7 Thorsten Leemhuis 2004-11-22 03:19:13 EST
Created attachment 107167 [details]
64 bit xorg.conf
Comment 8 Thorsten Leemhuis 2004-11-22 03:19:35 EST
Created attachment 107168 [details]
lspci, lspci -n , lspci -v
Comment 9 Thorsten Leemhuis 2004-11-22 03:21:39 EST
attachment id=107166 / comment #6 is just FYI: This is a working 32
bit driver from
http://www.viaarena.com/downloads/drivers/video/K8M800/k8mxf40044_20040511.zip
Comment 10 Mike A. Harris 2004-11-29 17:05:02 EST
This is the type of change that really requires X.Org to make first
in the upstream sources.  Please file a feature request in the
X.org bugzilla at http://bugs.freedesktop.org in the "xorg"
component, requesting the 'via' driver be enabled on AMD64
for CVS head, as there are AMD64 boards out there which have
this chipset on them now.

The driver may not be fully 64bit clean, having not been tested
previously on 64bit architectures, but once it's enabled on
X.Org CVS head for a while, presumeably any kinks in it will
get ironed out over the next development cycle.

Once you've filed your request to X.org bugzilla, paste the URL
here and we will track the status in the upstream tracker.

Thanks in advance.
Comment 11 Thorsten Leemhuis 2004-11-30 12:56:35 EST
Reported upstream:
https://bugs.freedesktop.org/show_bug.cgi?id=1973

Thanks Mike.
Comment 12 Mike A. Harris 2004-12-01 00:02:25 EST
Ok, adding to our internal tracker, and setting status to "UPSTREAM".

Thanks.

Note You need to log in before you can comment on or make changes to this bug.