Bug 138834 - Installer crashes at end of "preparing RPM transaction" on NFS install
Installer crashes at end of "preparing RPM transaction" on NFS install
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-11 09:45 EST by Tony Molloy
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-11 14:04:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tony Molloy 2004-11-11 09:45:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20041005

Description of problem:
I'm trying to do a NFS install of Fedora-3. I download the
distribution and prepare for install. Install, everything works OK.

Download the updated rpms. Copy them to the NFS mounted directories
and tidy up the directories, remove duplicate rpms.

Run genhdlist

genhdlist --productpath Fedora /path-to-NFS-dir

Seems to run OK, no errors.

Start install, gets as far as the end of " preparing RPM transaction"
screen then exits abnormally.

The only thing I noticed was the following message on the <ALT F3> screen 

WARNING: not all packages in hdlist had order tag



Version-Release number of selected component (if applicable):
anaconda-10.0.1.2-1

How reproducible:
Always

Steps to Reproduce:
1. Update the rpms on the distribution
2. Run genhdlist --productpath /path-to-NFS-dir
3. Start install
    

Actual Results:  
Installer exits abnormally after getting to 
"preparing RPM transaction" screen

Expected Results:  
Installer should have installed Fedora 3

Additional info:
Comment 1 Scott Dowdle 2004-11-11 11:26:09 EST
I also experienced the same problem.  Setup install server, updated
packages, ran genhdlist.  Tried the install, and the install exits
just as Tony Molloy mentioned.

At first I thought it was the hardware I was trying to install on, but
I've tried three different machines and it does the same thing in
every case.

Also, to eliminate the possibility of a mistake during the setting up
of the install server (a bad or duplicate package or something), I
deleted the directory tree and copied the packages from CD.  Same
problem.  Then from DVD.  Then from -o loop mounted .iso images that
checksum'ed fine... so to the best of my knowledge, it isn't anything
I've done wrong... and this HAS worked for me in the past.

Please HELP! 
Comment 2 Scott Dowdle 2004-11-11 11:32:15 EST
Somehow I forgot to check "Add Me to Cc List".  Please ignore this
second post.  It is just so I could add myself to the Cc List. :)
Comment 3 Jeremy Katz 2004-11-11 14:04:09 EST
You also need to do the file order with pkgorder.
Comment 4 Stuart 2004-11-13 23:06:56 EST
Well, I'm experiencing this as well, but with HTTP installs.  I've 
been using a HTTP install with an updated set of RPMs since about 
RedHat 9 and suddenly it seems broken in FC3.

I'm looking thru the code of anaconda in FC3 and see that in 
packlages.py if package order information is not present, RPM will 
generate it on the fly.  This has worked in the past, but seems to 
cause anaconda to crash unexpectely now.

After reading the comment from Jeremy, I have tried the process of 
running genhdlist, then pkgorder, and then rerunning genhdlist w/ the 
package order information (a process which seems to take forever 
compared to a single genhdlist).  When I did an HTTP install after 
that, things progressed a bit further but still failed (sorry, but I 
don't have more detail on that error at the moment).  I'm currently 
trying to figure out why anaconda is failing and how to fix it, but 
know next to nothing about Python and see that with the cramfs 
filesystem testing any changes is rather involved.
Comment 5 derrien 2004-11-16 13:02:57 EST
With genhdlist then pkgorder then genhdlist installation via NFS works
but something strange :

On a PC Fedora 2 + anaconda-10.1.0.2-1

export PYTHONPATH=/usr/lib/anaconda
/usr/lib/anaconda-runtime/pkgorder --product Fedora $VERSION i386

No problem.

But on Fedora 3 same things give a lot of :

warning: ignore package name relation(s) [0]    pango-gtkbeta-devel ->
pango-gtkbeta
warning: ignore package name relation(s) [1]    XFree86 -> Mesa
warning: ignore package name relation(s) [2]    xorg-x11 -> Mesa
warning: ignore package name relation(s) [3]    compat-glibc -> db2
warning: ignore package name relation(s) [4]    compat-glibc -> db1
warning: ignore package name relation(s) [5]    pam -> initscripts
warning: ignore package name relation(s) [6]    initscripts -> sysklogd
warning: ignore package name relation(s) [7]    arts -> kdelibs-sound
warning: ignore package name relation(s) [8]    libgnomeprint15 ->
gnome-print
warning: ignore package name relation(s) [9]    nautilus ->
nautilus-mozilla
warning: ignore package name relation(s) [10]   tcl -> postgresql-tcl
warning: ignore package name relation(s) [11]   libtermcap -> bash
warning: ignore package name relation(s) [12]   modutils -> vixie-cron
warning: ignore package name relation(s) [13]   ypbind -> yp-tools
warning: ignore package name relation(s) [14]   ghostscript-fonts ->
ghostscript
warning: ignore package name relation(s) [15]   usermode -> util-linux
warning: ignore package name relation(s) [16]   control-center ->
xscreensaver
warning: ignore package name relation(s) [17]   kdemultimedia-arts ->
kdemultimedia-libs
warning: ignore package name relation(s) [18]   initscripts -> util-linux
warning: ignore package name relation(s) [19]   XFree86-libs ->
XFree86-Mesa-libGL
warning: ignore package name relation(s) [20]   xorg-x11-libs ->
xorg-x11-Mesa-libGL
warning: ignore package name relation(s) [21]   mysql -> perl-DBD-MySQL
warning: ignore package name relation(s) [22]   ghostscript -> gimp-print
warning: ignore package name relation(s) [23]   bind -> bind-utils
warning: ignore package name relation(s) [24]   perl -> mod_perl
warning: ignore package name relation(s) [25]   perl -> perl-Filter
warning: ignore package name relation(s) [26]   coreutils -> pam
warning: ignore package name relation(s) [27]   perl -> mrtg
warning: ignore package name relation(s) [28]   perl-Date-Calc ->
perl-Bit-Vector
warning: ignore package name relation(s) [29]   glibc-debug -> glibc-devel
warning: ignore package name relation(s) [30]   xinitrc -> XFree86
warning: ignore package name relation(s) [31]   xinitrc -> xorg-x11
warning: ignore package name relation(s) [32]   xemacs -> apel-xemacs
warning: ignore package name relation(s) [33]   gstreamer-tools ->
gstreamer
warning: ignore package name relation(s) [34]   gimp -> gimp-print-plugin
warning: ignore package name relation(s) [35]   redhat-lsb -> redhat-lsb
warning: ignore package name relation(s) [36]   info -> ncurses
warning: ignore package name relation(s) [37]   aspell -> aspell-en
warning: ignore package name relation(s) [38]   dbus -> dbus-glib
warning: ignore package name relation(s) [39]   openjade -> docbook-dtds
warning: ignore package name relation(s) [40]   xemacs -> xemacs-sumo
warning: ignore package name relation(s) [41]   ncurses -> gpm
warning: ignore package name relation(s) [42]   cyrus-sasl -> openldap
warning: ignore package name relation(s) [43]   initscripts -> kernel
warning: ignore package name relation(s) [44]   initscripts -> kernel-smp
warning: ignore package name relation(s) [45]   rpm-libs -> rpm
warning: ignore package name relation(s) [46]   httpd -> httpd-suexec
warning: ignore package name relation(s) [47]   php -> php-pear
warning: ignore package name relation(s) [48]   gnome-python2 ->
gnome-python2-bonobo
warning: ignore package name relation(s) [49]   openoffice.org-libs ->
openoffice.org
warning: ignore package name relation(s) [50]   gtk+ -> gdk-pixbuf
warning: ignore package name relation(s) [51]   nautilus ->
nautilus-cd-burner
warning: LOOP:
warning: removing initscripts-7.93.5-1 "Requires: /sbin/nash" from
tsort relations.
warning:     initscripts-7.93.5-1                     Requires: /sbin/nash
warning: removing mkinitrd-4.1.18-2 "Requires: lvm2" from tsort relations.
warning:     mkinitrd-4.1.18-2                        Requires: lvm2
warning: removing lvm2-2.00.25-1.01 "Requires: kernel >= 2.6" from
tsort relations.
warning:     lvm2-2.00.25-1.01                        Requires: kernel
>= 2.6
warning:     kernel-2.6.9-1.667                       PreReq:
initscripts >= 5.83

Note You need to log in before you can comment on or make changes to this bug.