Bug 13884 - Problem with nntp-service
Summary: Problem with nntp-service
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xinetd   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
high
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard: Winston rc1
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-13 07:38 UTC by Inger Karin Haarbye
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-02 16:22:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/xinetd.d/nntp (192 bytes, text/plain)
2000-07-13 21:24 UTC, Inger Karin Haarbye
no flags Details

Description Inger Karin Haarbye 2000-07-13 07:38:52 UTC
I have upgraded from 6.2 to beta3. Leafnode was installed on my
6.2, and worked well. On upgrade beta3 didn't get the nntp-service from
the old inetd.conf into the new xinet.d. I had to do it with
inetdconvert.

When trying to get in contact with my local nntpserver - nothing happens
except that "syslogd" and "tcpd /usr/sbin/leafnode" consumes ca. 86% of
my CPU!
I don't get any error-messages, my computer is just working and working,
and there is a lot of  activity on my harddisc.

And this is what "syslogd" is doing - 20 times every minute the last 4
hours - in /var/log/secure:
(until I kill "tcpd /usr/sbin/leafnode" and restart syslogd)

Jul 11 19:24:04 opuntia tcpd[2010]: warning: can't get client address:
Invalid argument
Jul 11 19:24:04 opuntia tcpd[2010]: connect from unknown
Jul 11 19:24:04 opuntia tcpd[2010]: warning: can't get client address:
Invalid argument
Jul 11 19:24:04 opuntia tcpd[2010]: connect from unknown

Comment 1 Trond Eivind Glomsrxd 2000-07-13 19:02:35 UTC
The conversion problem is in the installer, which has since been fixed. Can you
atttach the leafnode service file from /etc/xinetd.d? You don't need tcpd
either... try without it, and see if the problem continues.

Finally, if the problem continues, wait for the next beta and see if it
disappears - I have a compiler bug suspected for this, which we have fixed since
then (-foptimize-sibling-calls, part of -O2)(or try rebuilding xinetd and
libwrappers on your computer yourself, with -O1) - please update this bug after
the next release (still a problem or if it's fixed)

Comment 2 Inger Karin Haarbye 2000-07-13 21:24:53 UTC
Created attachment 1087 [details]
/etc/xinetd.d/nntp

Comment 3 Trond Eivind Glomsrxd 2000-07-21 22:24:06 UTC
Still a problem when updating the selected components from beta4?
(BTW: no need to use tcpd, libwrapper support is compiled into xinetd)

Comment 4 Trond Eivind Glomsrxd 2000-07-27 18:27:15 UTC
Please test if the problem persists with beta 5

Comment 5 Glen Foster 2000-07-30 22:58:50 UTC
This defect is considered MUST-FIX for Winston Release-Candidate #1

Comment 6 Inger Karin Haarbye 2000-08-01 13:37:34 UTC
The problem is the same in beta5. I have installed beta5 (not upgraded this
time). I installed the same rpm of leafnode from redhat-contrib. Converted the
nntp-service with inetdconvert. My /etc/xinetd.d/nntp file looks (still) like
this:
# Converted by inetdconvert
service nntp
{
	disable	= no
	socket_type		= stream
	protocol	  	              = tcp
	wait			= yes
	user			= news
	server			= /usr/sbin/tcpd
	server_args		= /usr/sbin/leafnode 
}

To try "without tcpd",  how? With server=/usr/sbin/leafnode and no
server_args??

Comment 7 Trond Eivind Glomsrxd 2000-08-01 13:56:28 UTC
Yes, with server=/usr/sbin/leafnode.No server arguments. Can you try recompiling
the leafnode source rpm (rpm --rebuild) and see if the problem persists? TIA.

Comment 8 Inger Karin Haarbye 2000-08-01 18:06:17 UTC
I have now recompiled from SRPM: leafnode-1.9.14-1.src.rpm

My /etc/xinetd.d/nntp looks like this:

service nntp
{
	socket_type		= stream
	protocol		= tcp
	wait			= yes
	user			= news
	server			= /usr/sbin/leafnode
	disable			= no
}

The result is a little bit different, but still problem. From /var/log/secure:

Aug  1 19:55:18 opuntia xinetd[537]: START: nntp pid=919 from=<no address>
Aug  1 19:55:24 opuntia xinetd[537]: START: nntp pid=920 from=<no address>
Aug  1 19:55:29 opuntia xinetd[537]: START: nntp pid=921 from=<no address>
Aug  1 19:55:34 opuntia xinetd[537]: START: nntp pid=922 from=<no address>

again and again until the service stops, and /var/log/messages:

Aug  1 19:55:18 opuntia xinetd[537]: warning: can't get client address: Invalid
argument
Aug  1 19:55:50 opuntia last message repeated 6 times
Aug  1 19:56:52 opuntia last message repeated 12 times
Aug  1 19:57:54 opuntia last message repeated 10 times
Aug  1 19:58:55 opuntia last message repeated 142 times
Aug  1 19:59:06 opuntia last message repeated 33 times
Aug  1 19:59:06 opuntia xinetd[537]: nntp service was deactivated because of
looping


Comment 9 Trond Eivind Glomsrxd 2000-08-02 16:22:36 UTC
OK - I can reproduce this. I'm looking into it now.

Comment 10 Trond Eivind Glomsrxd 2000-08-02 18:18:21 UTC
Ah... set wait=no. I'm making the convert script do that.


Note You need to log in before you can comment on or make changes to this bug.